Bug details

Problem with changing the cursor to text

Hello. After running the latest version of InDesign CC 2019 v. 14.0, I have a problem with changing the cursor to text. It takes about 50 seconds. This happens each time you launch InDesign.

154 votes
Sign in
Password icon
Signed in as (Sign out)

We’ll send you updates on this idea

Darek shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

Hello All,

Thank you for your patience all this while.
This issue is now fixed in the latest update (Id 14.0.1) of InDesign CC.
If you are unable to see the update notification yet, open the menu (three dots) from the top-right of Creative Cloud desktop application and click on ‘Check For App Updates’.

Once the update button is shown against InDesign CC, click on the button to update your InDesign to Id 14.0.1 for the fix of the issue.
Do let us know in the comments, if you face any problem with the new update.

List of fixed issues can be found at: helpx.adobe.com/indesign/kb/fixed-issues.html

InDesign Team


Sign in
Password icon
Signed in as (Sign out)
  • Robyn Budd commented  ·   ·  Flag as inappropriate

    This is NOT fixed!!! AND it renders my program, upon which my livelihood depends, completely unusable.
    What's a workaround? I need this program, for which I pay monthly, to be dependable. Please advise!!!

  • Anonymous commented  ·   ·  Flag as inappropriate

    Still having this issue. When will it be resolved? Sick of paying for damaged goods.

  • Anonymous commented  ·   ·  Flag as inappropriate

    We - your paying customers - are now 5 MONTHS on from when this issue was first raised and this has still not been fixed. This is not acceptable. CC 2019 appears to have been a rushed release with more bugs than the entomology department at the Smithsonian.

    I just upgraded to CC2019 from 2018 and am having serious regrets.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Hello Adobe...This is a serious issue in InDesign CC19 that makes working with type very frustrating. The 14.0.1 update did not address this issue. Abhinav Kaushik, please give us all an update on your progress in addressing this issue.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Abhinav Kaushik

    Can you have any smarter solution to share rather than repeat this???

  • Dominic Forbes commented  ·   ·  Flag as inappropriate

    Glad it's not just me, thought I was going mad. Latest version of InDesign practically unusable on Mojave. CC18 was rock solid. Photoshop and Indesign both less responsive and more buggy in CC19.

  • Andy H commented  ·   ·  Flag as inappropriate

    Testing Id (14.0.1) using MacBook Air running Mojave - problem with hand tool not changing when another tool (e.g. frame tool or type tool) is selected seems to have persisted. Closing Id down and relaunching does not assist. Fortunately I'm on a free trial, otherwise this could be an expensive mistake to purchase.

  • ValdisBB commented  ·   ·  Flag as inappropriate

    This problem hasn't been fixed!!!!!! I think it has something to do with the new Properties panel... (a totally pointless innovation!!!!! In fact, it backs up the existing control panel which previously worked very well!) When you remove the control panel, this problem disappears. But how to work without a control panel?!! Panel Properties IS NOT A GOOD ALTERNATIVE!!!

  • VL commented  ·   ·  Flag as inappropriate

    when selecting txt to change font - indesign becomes unusable - have to goto task manager/end task to start app again.

  • Haeme Ulrich commented  ·   ·  Flag as inappropriate

    The problem is still persistent here ( My workaround: Set the text cursor first manually. After this (once) I can work with the shortcut.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Still have the problem of the Text tool switching back to cursor tool (after I press the "T" shortcut), after a split second. This makes InDesign virtually unusable in laying out and designing. Please fix!!

  • Gareth Lind commented  ·   ·  Flag as inappropriate

    I have kept CC 2018 on my system because there are always issues. When I work in 2018 and select the Type Tool using "T", I can instantaneously start formatting. Whereas, using CC 2019, there is a significant delay, causing me to move the text box (since I am still haven't been switched from the Selection Tool) rather than selecting the text to format. It's a simple matter of lag time, as if the new text preview options are weighing down the system (that's a guess). I may rever to 2018 for most work until this is fixed. Very irritating, and it erodes time away from what used to be streamlined.

← Previous 1 3 4 5 6 7 8

Feedback and Knowledge Base