Bug details

Proportional Scaling Using Shift Button Not Working

In the 2017.1 release of InDesign, the ability to hold Shift and scale objects proportionally seems to have disappeared. I know for me this is a major functionality problem that is increasing the time I have to spend on current projects. I've checked support forums and others are encountering this problem, but I haven't yet seen a solution.

81 votes
Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)

We’ll send you updates on this idea

Layne Ransom shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

Hello All,

Thank you for your patience all this while; we really appreciate your support!

Our investigation suggests that one of common reasons for the problem is that certain software (mostly antivirus and other security applications) and browser extensions happen to enable “Secure Keyboard Entry” on Mac machines due to which some keys such as Shift key in this case do not perform the desired action in InDesign.

For now I request you to follow the below provided KB doc for the quick workaround of the problem.
https://helpx.adobe.com/indesign/kb/features-do-not-work-keyboard-keys-mac.html

In the comments section many of the users have confirmed that disabling Webroot SecureAnywhere (a security app) has resolved the issue for them. Please note that, the problem may not be related to a particular software; there could be a different application or antivirus which might be causing the problem by enabling Secure Keyboard Entry on Mac.

Regards,
Abhinav Kaushik
InDesign Team

236 comments

Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
Submitting...
  • Crisy commented  ·   ·  Flag as inappropriate

    First they changed the shift button in Photoshop
    Now it no longer even works in InDesign

    Adobe, you're killing me!

    Please provide another solution other than "close your internet browsers" That's honestly not a solution.....

  • Patsla commented  ·   ·  Flag as inappropriate

    Has anyone found a work around? This is very annoying and time consuming.

    E.g. I have an image I want to scale in an image box, I create the box, I do not want it to fit the height or width by using the shortcut, I want to be able to size proportionally so I can crop inside the image box.

    Right now the only way I have found to scale proportionally is by increasing the box size - then use the short cut - then resize the image box around the portion of the image I want cropped. Ask me how much time it takes to do this to get what I am looking to accomplish? Too much time! Thats how much.

    ADOBE, fix this!These online programs are too costly to have this type of malfunction, it has been going on for far too long.

  • Anonymous commented  ·   ·  Flag as inappropriate

    I don’t have the webroot security app, so that solution didn’t help. However, someone posted to quit Safari and that worked for me. Thanks. I’d still like this bug fixed so I can use the internet.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Designers need to resize all the time. This bug is wasting so much time. Please fix it. I’m avoiding InDesign at all costs and designing new files only in Illustrator.

  • Jules commented  ·   ·  Flag as inappropriate

    This is very frustrating! My old PC died and I had lost my old indesign disc in a house move, shelled out a lot of money for a new disc and now can't re-size!

  • Anonymous commented  ·   ·  Flag as inappropriate

    I also had problems with 'shift' not constraining proportion or 'Alt' not duplicating on Mack book pro 2019 15 inch with Indesign CC 14.0.2
    Quitting both Safari and Google Chrome fixed it for me. Very strange.

  • sep commented  ·   ·  Flag as inappropriate

    What worked for me:
    - Preferences > General > Reset Preferences on quit
    - Restart photoshop

    Command keys etc working as they should.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Same with me. Installed CC2019 and proportional scaling using the black arrow and holding down the shift key is no longer working. I have reset the preferences and still no good.

  • JDW commented  ·   ·  Flag as inappropriate

    Having this same issue has anyone found a fix. It is very frustrating not having this feature working. I am on new MacBook Pro 15" as well. PLEASE FIX THIS

  • Gabbi commented  ·   ·  Flag as inappropriate

    It's also happening to me. I'm using my new MacBook Pro with the Touchbar, the 15" one. However, they got me the 13" one at work, and InDesign doesn't have that problem on that one, and I also don't have that problem on my old 13" MacBook Pro from 2012, so I really don't know what the issue might be. Pleeeeaaaase fix this! D:

  • Cameron Muir commented  ·   ·  Flag as inappropriate

    Recycling this comment as it solved the issue for me: **CLOSE LASTPASS IF YOU ARE USING**

    I was able to scale immediately after closing this app.

  • Linda commented  ·   ·  Flag as inappropriate

    None of the work-arounds are working. I can't scale my images without going through way too many steps. Does anyone have some cyber god of graphic design I can pray to? This is seriously debilitating. Thank you!

  • Jen commented  ·   ·  Flag as inappropriate

    I am having this issue too - in fact none of the Shift or Option short cuts are working. I have got a large brochure to work on next week and this ridiculous issue is going to cause me severe problems. I have not got Webroot here, nor any other security software. I use Safari as a browser - quitting it has not made any difference to InDesign. Is there a fix that is easy to follow - I'm not a techie! Thanks!

  • Andreas Dobos commented  ·   ·  Flag as inappropriate

    In the actual version the scaling an image with shift doesn't work properly. It is possible to scale umproportional although the shift button is pressed.

  • Marie commented  ·   ·  Flag as inappropriate

    Also am having this problem, very annoying, the whole point of InDesign is to do layout which is impossible with this bug.

  • t commented  ·   ·  Flag as inappropriate

    This has nothing to do with webroot -- I don't have that and it's not working. FIX THIS. Your lates update didn't fix it. FIX IT.

← Previous 1 3 4 5 11 12

Feedback and Knowledge Base