Bug details

Proportional Scaling Using Shift Button Not Working

In the 2017.1 release of InDesign, the ability to hold Shift and scale objects proportionally seems to have disappeared. I know for me this is a major functionality problem that is increasing the time I have to spend on current projects. I've checked support forums and others are encountering this problem, but I haven't yet seen a solution.

78 votes
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Layne Ransom shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

Hello All,

Thank you for your patience all this while; we really appreciate your support!

Our investigation suggests that one of common reasons for the problem is that certain software (mostly antivirus and other security applications) and browser extensions happen to enable “Secure Keyboard Entry” on Mac machines due to which some keys such as Shift key in this case do not perform the desired action in InDesign.

For now I request you to follow the below provided KB doc for the quick workaround of the problem.
https://helpx.adobe.com/indesign/kb/features-do-not-work-keyboard-keys-mac.html

In the comments section many of the users have confirmed that disabling Webroot SecureAnywhere (a security app) has resolved the issue for them. Please note that, the problem may not be related to a particular software; there could be a different application or antivirus which might be causing the problem by enabling Secure Keyboard Entry on Mac.

Regards,
Abhinav Kaushik
InDesign Team

231 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Jake commented  ·   ·  Flag as inappropriate

    Same issue. It happens randomly while I'm working midway through a project in InDesign. Proportional scaling and moving aren't working. I restarted my computer yesterday and it worked again. Midway through today the issue started up again. I don't have any antivirus or what not as mentioned resolved section. I do use internet browsers and am required to in order to do my job, so that's not a solution.

  • Adi commented  ·   ·  Flag as inappropriate

    I have the same problem. Frustratring. Please fix!!!!

  • Anonymous commented  ·   ·  Flag as inappropriate

    Closing all browsers also worked for me. (Not just Chrome, needed to be all of them). That is Effing nuts. Fix this bug.

  • Aone commented  ·   ·  Flag as inappropriate

    I also have this problem - missing important deadlines because of the time it's taking me to sort this out - total nightmare!!! And it's since buying a new Mac. Great. Glad I've paid the extortionate amount for Apple for this kind of service!

  • aeclark commented  ·   ·  Flag as inappropriate

    I now have this problem. It started in the middle of modifying a document! I no longer have use of the shift key or the shift/command key.

  • mystreonattack commented  ·   ·  Flag as inappropriate

    I had this issue and it was caused by having Google Chrome open - close Chrome and your problem is solved.

  • Tbonz commented  ·   ·  Flag as inappropriate

    Found that it will now scale proportionally by default without the need to hold shift.

  • Tom Moulaert commented  ·   ·  Flag as inappropriate

    Same problem over here! Closing Chrome browser solved the problem! But this isn't really solving the problem. Isn't it? I needed to draw 45º lines and therefor had to close my browser sessions. Please fix this! InDesign CC2019 (14.0.1) on macOS High Sierra (10.13.6). Thank you!

  • Anonymous commented  ·   ·  Flag as inappropriate

    I dont have webroot on my Mac. But I do have the problem with the Shift key, in Indesign and photoshop by the way. And proportionally scale...

  • Anonymous commented  ·   ·  Flag as inappropriate

    This is very frustrating and causing delays. I have been using the Adobe software since the 1980's and have never been without the use of the shift tool to constrain proportions or keep a line straight. Or what about using the command/option/shift tools to copy and keep the object on the same plane? That is gone too. Adobe fix this problem with your software...

  • Anonymous commented  ·   ·  Flag as inappropriate

    Absolutely infuriating! How can something as fundamental as this get broken?

  • Markus commented  ·   ·  Flag as inappropriate

    Hey ADOBE, about 200 people with this issue in this list (that does not exist not in my language German)!
    When will you find a solution to this time wasting issue?? And this is ONLY ONE serious issue I have with the actual Creative Cloud apps. This hurts when I receive my adobe bill EVERY MONTH!!!

  • Anonymous commented  ·   ·  Flag as inappropriate

    having the same issue can't do preferences and the scale tool is infuriating. FIX IT ADOBE, you're killing my production time!!!!

  • Anonymous commented  ·   ·  Flag as inappropriate

    I struck a quick solution - close down all your web browsers and see what happens. Worked for me.

  • MvB commented  ·   ·  Flag as inappropriate

    This morning I had the same issue. Workaround that helps at my system:

    1. Stop InDesign
    2. Delete all preferences of InDesign (<user>/library/Preferences/Adobe Indesign)
    3. Restart InDesign (everything is at default now)

    Scaling does work now (proportionally) when pressing Cmd+Shift and moving corner of (group of) pictures.

  • Niina commented  ·   ·  Flag as inappropriate

    Still having this annoying problem! Scale does not work as it should. This is really making my work impossible as I should be sending the file tomorrow morning to a customer!

  • Brooke commented  ·   ·  Flag as inappropriate

    I am having the same issue still. Using the shift key doesn't keep objects traveling along the same axis and holding down the Option key does not copy like it once did. I have no anti-virus software that would be causing this problem. Hopefully this can get resolved quickly.

Feedback and Knowledge Base