Adobe InDesign: Bugs

When filing a new bug, please provide:

  1. Version of Adobe InDesign, InCopy or InDesign Server
  2. Steps to reproduce the issues
  3. Expected result
  4. Actual result
  5. Test file, screenshot, video or GIF capturing the issue (optional)
If you are facing a crash in InDesign, please submit the crash report as well. How to Submit Crash Report
Join the InDesign Prerelease Program to try out the new features and the bug fixes that are available in beta builds.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Cannot "place" MathType eps file correctly into InDesign - InvalidFont error

    InDesign CC 13.1

    Steps to Reproduce

    1.In a ID document, use File > Place
    2.Select the attached eps file, which is an eps file created by MathType
    3.Place the eps file

    Expected Result: The eps to place the image correctly

    Actual Result: Before the eps is placed, the error is seen: "InvalidFont error occurred creating the screen display for the imported EPS. The EPS will draw as a gray box. The actual EPS may not print and will not export as PDF. Do you still want to place this file? Yes/No?

    Clicking Yes results in only a gray box.

    Cannot

    6 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  2. Cannot place this file. Invalid PNG file

    In 15.0.3, my publication was print ready

    I updated to 15.1 as I normally would.

    In 15.1, particular .png files were missing. I tried to place the missing images as usual but got the error - Cannot place this file. Invalid PNG file'.

    I rolled back to 15.0.3 and am now able to place the self same files.

    Update bug?

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    14 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
    FIXED  ·  amaarora responded

    The fix is now publicly available in the latest InDesign update, 15.1.1

    Please update to this latest version to get the fix.


    Adobe InDesign team

  3. Links panel misreporting ICC profiles

    I would like the ICC column in the Links panel to actually show the ICC profile of the linked images. Right now it's misreporting image ICC profiles as "Document CMYK" when they are not, in fact, in that color space.

    I have an InDesign document that's using a CMYK profile of "U.S. Web Coated (SWOP) v2". It incorporates two copies of the same image, each with different CMYK profiles, "GRACoL 4c BW" and "CGATS21_CRPC1", respectively.

    Nevertheless, the ICC Profile column in the links tab reports that both of these images have the "Document CMYK" profile. As far as I can…

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  4. InDesign 2020 v 15.0.1, Mac OS Catalina, indd/idml legacy layouts within packaged folders, images disappear

    InDesign 2020 v 15.0.1, Mac OS Catalina. When opening legacy versions of indd or idml documents within packaged folders, images flash/display briefly, then most if not all, disappear. The only solution seems t be to re-link each graphic individually.

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  5. Links within linked Indesign files appear pixellated even if the links are updated.

    Linked images within linked Indesign files appear pixelated, even if the links are updated. It's temporarily fixed by relinking the file – but it goes back to appearing pixelated when the file is reopened. This has only happened recently and has never been a problem in the past.

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  6. Links from CC Library suddely missing and can't be relinked

    I sometimes have a problem with links from the CC Libraries, the links work fine when I save and close the file. But then sometimes when I open the INDD-file the day after it says that the links are missing, and when I try to relink it just say that "Either the file doesn't excist, you do not have read permissions to it or the file is used in another application".

    But none of the options in the dialog box are correct, the files in the library still works fine in other documents. I have no idea how to fix…

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  7. Object Layer Options not working using Photoshop files

    I've placed the same layered photoshop files into ID three times to show how an animation works. Going to 'Object Layer Options' and clicking 'Keep Visibility Layer Overrides' is meant to keep your selected layers visible, even if the Photoshop is resaved. This no longer works. Once the link updates, all three update to look the same and forget which layers i've told it to show. Why?

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  8. [INDD 2020 and 2021] Missing font in placed SVG is not detected by Preflight or Type > Find Fonts…

    [ 2020 ][ 2021 ] A missing font in a placed SVG does not show

    If you open a document with a placed SVG where a font is not embedded the missing font does not show with:
    [1] Type > Find Fonts…
    [2] Preflight

    If you export that InDesign document to IDML and open the IDML file with InDesign the missing font is showing as missing in Preflight and Type > Find Fonts… .
    As soon as you save the IDML as InDesign document, close and open it again, the missing font is not detected again. Neither with Preflight nore…

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  9. Flipped text in PDF created from Canva

    When placing a PDF with certain stylized fonts, the text is being flipped and enlarged. Seems to be specific to Mac OS.

    PDF docs have been created in Canva. They appear correctly when opened in Adobe Acrobat Pro, both on Windows and Mac. They are being placed in InDesign, and at that time the text titles being flipped and enlarged. I am working from v. 16.0.1. This was not an issue in previous versions. When I use png docs instead, and place those, I have no issues. I have been an Indesign user for about 3 years.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  10. image damaged or incompatible

    "Error encountered while reading JPEG image. Image might be damaged or incompatible. Resave the image with a different setting and try again."
    I have a set of at least 100 JPEGs that work perfectly fine with any other program, but won't load in Indesign

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  11. Alt text not appearing for images across spreads

    in ID 2020, image across double-page spreads will generate an alt-text error when exported to accessible PDF. This problem goes away when saved as IDML and opened in ID 2019.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  12. Can't Place Images with Applescript on MacOS 10.15 Catalina

    InDesign 15.0.1

    The Place command now fails in Applescript, following an upgrade to Catalina.
    The "Image Catalog" sample script also fails to place the images in the same manner. Image placement fails with an error 1708, <<the file string>> doesn't understand the "place" message.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    7 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  13. not exporting to jpg

    Since the most recent update, I can no longer export ID file to jpg or png. The files just shows as zero bytes. I am able to save as pdf and then save as image. But need to be able to export to jpg and png. Please fix. Thanks

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  14. Google File Stream Images taking a long time to update in Indesign

    Since upgrading to Mac OSX Catalina and adobe 2020 I have issues with google file stream and indesign.

    When I open a document with images that are saved on google drive and then open in photoshop or illutrator to edit and then save and go back to indesign, the images are showing as needing updated by indesign (yellow triangle) however the rotating / update round arrows icon is greyed out and I can't update the image. I have to wait several minutes before the image updates on indesign.

    I have contacted Adobe support and apple support and neither is claiming…

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  15. [Copyright-Notice] Automatic Caption for images

    When creation an automatic caption for images it is possible to chose the option "Copyright" but this actually referts to the IPTC - Core "Source" (Quelle) and not the "Copyright - Notice" which is used by Adobe Stock.

    So it is not possible to automaticly use the Adobe Stock Copyright notice because InDesign seems to read the wrong MetaData field.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  16. "Go back on roll over" interactive button state checked/greyed out

    I was working on an interactive project and found that the "go back on roll over" option becomes turned on and greyed out so you cannot un-check the box when adding an "upon release" action to a button. I initially could NOT figure out why this was happening, and it was totally screwing up my on-click actions in my project.

    Eventually, I think I figured out that it seems to happen when you create a button, add an "on roll over" action and check the box "go back on roll off", then create ANOTHER action (like "on click"), and then…

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  17. Clicking on image doesn't show it in the Links panel

    Clicking on an image within a frame doesn't show it in the Links panel, so I have to scroll through the list of links to find the image - This sometimes works, sometimes does not.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  18. When I copy and paste from Illustrator CC into InDesign CC, instead of the vector art I get this text.

    <!-- Generator: Adobe Illustrator 22.1.0, SVG Export Plug-In -->
    <svg version=”1.1”
    xmlns=”http://www.w3.org/2000/svg” xmlns:xlink=”http://www.w3.org/1999/xlink” xmlns:a=”http://ns.adobe.com/AdobeSVGViewerExtensions/3.0/”
    x=”0px” y=”0px” width=”5.9px” height=”5.9px” viewBox=”0 0 5.9 5.9” style=”enable-background:new 0 0 5.9 5.9;”
    xml:space=”preserve”>
    <style type=”text/css”>
    .st0{clip-path:url(#SVGID2);fill:none;stroke:#231F20;stroke-width:0.421;stroke-miterlimit:3.864;}
    .st1{clip-path:url(#SVGID4);fill:none;stroke:#231F20;stroke-width:0.421;stroke-miterlimit:3.864;}
    </style>
    <defs>
    </defs>
    <g>
    <defs>
    <rect id=”SVGID_1_” width=”5.9” height=”5.9”/>
    </defs>
    <clipPath id=”SVGID_2_”>
    <use xlink:href=”#SVGID_1_” style=”overflow:visible;”/>
    </clipPath>
    <circle class=”st0” cx=”3” cy=”3” r=”2.8”/>
    </g>
    </svg>

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    9 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  19. Placing illustrator files is very very very slow after update

    After updating AI and INDD, placing AI files into INDD is taking a very long time. I made an update to an AI file that was placed into an existing INDD files that contains 13 placed AI files. I only updated a few of the linked AI files. Prior to the AI and INDD update, updating these placed links took a few seconds each max. Now, just to update the two links takes about 2 minutes.

    This MAY be an AI bug, but I don't know how make that determination as I updated bothat the same time.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Need More Info  ·  1 comment  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  20. Image tagged with sRGB, but InDesign assigns AdobeRGB (Workspace) and displays incorrect colors

    I´m using Indesign 13.0.1 x64

    To recreate please use the following steps (I have AdobeRGB as Working-space and preserve profiles):
    1. Create a new document
    2. Place the attached Image "Portrait_Edip-original.jpg"
    3. Look for the Profile in the links-panel

    The image has sRGB but displays as Workspace RGB but my workspace is AdobeRGB and also the colors are incorrect.
    Bridge and Photoshop both show the right profile.
    When i open the image in Photoshop and save it as jpeg it works in InDesign.

    I have this issue from time to time but now i´m sure it´s a bug.

    I work…

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

Feedback and Knowledge Base