Bug details

InDesign CC (13.0.1.) - Often can't save as InDesign-Document (error code 0)

InDesign often says that it can't save my InDesign-Document, because its damaged (error code 0) . It damage my files, so that i've to save as IDML.

Annoying.

Cant't reproduce the problem.
I work local, so it can't be an connection-problem.

13 votes
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

AP shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

We’ve been able to identify one scenario in which the cache folder is not accessible while InDesign is launched resulting is the issue. The issue seems to be specific to MAC OS.
If you encounter the issue again, try to access the location “/Users//Library/Caches/Adobe InDesign/Version/13.0/en_US/InDesign Recovery/*” and create a file in the directory.

Workaround – Relaunch the application, Cache folder gets created and the problem is resolved.

We require more information to identify the root cause of the issue. Please provide following information via email to santalwa@adobe.com
1. Version of MAC OS (10.11.x, 10.12.x, 10.13.x)
2. Is InDesign cache and Preferences mounted on Network drive?
3. Any sync utility running on your machine, such as TimeMachine?

Thanks,
Adobe InDesign Team

17 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Matt commented  ·   ·  Flag as inappropriate

    I had this problem so many times too now. Wow. It puzzles me how a company like Adobe fails on huge issues like this. I mean people waste hundreds of hours on projects that go completely wasted. I saved my last one thanks to creating the folder /Users//Library/Caches/Adobe InDesign/Version/13.0/en_US/InDesign Recovery/* but that shouldn't even be a thing that we have to do. FIX IT ASAP

  • Anonymous commented  ·   ·  Flag as inappropriate

    Thank You Ravi.
    I didn't have to close the In Design, the folder "InDesign Recovery" just didn't exist under "“/Users//Library/Caches/Adobe InDesign/Version/13.0/en_US/", all i had to do was create it, and then i was able to save the documento.

  • Maria Welych commented  ·   ·  Flag as inappropriate

    I just updated my InDesign to the newest version (10.0.1 x64) today (1/24/19) on my Windows PC and now I cannot save any document I create. I've tried quiting and relaunching, and the same thing keeps happening. Whatever you did in the update broke my InDesign. It is useless to me now.

  • Laura commented  ·   ·  Flag as inappropriate

    I have this problem constantly. Work on an INDD doc, and then have to save as IDML. It happens across multiple documents almost every day. Would love to see this fixed. I have whatever the lates creative cloud version is, and am running Mac OS 10.13.2.

  • Stefanie commented  ·   ·  Flag as inappropriate

    Ever since I installed High Sierra (approx 1-2 weeks ago), nearly all my InDesign files have resulted in a damaged / corrupt error. (Could not complete your request because of a database error. The file "Malarkey_2Pg_Brochure_11_05_18.indd is damaged (Error code: 0). Please help! I try to copy all the content and open a new file as a way to save it and again, a corrupt error!

  • Wolfgang Housseaux commented  ·   ·  Flag as inappropriate

    Wow, that's a funny one for Friday!

    Cannot create new file.
    The file "Unknown document" is damaged (Error code:0)

    A QUIT and RESTART of InDesign fixed the problem, but you made me laugh!

    Have a nice day!

  • Anonymous commented  ·   ·  Flag as inappropriate

    I'm having the same problem with one file of a book. I can't get it to save the work I've just done and I don't know how to fix. I tried following the above address, but I have no Adobe InDesign in my Cache folder. I work with InDesign CC Mac OS version 10.13.6. I can't publish my book without this fix, so please advise how to solve. This is EXTREMELY FRUSTRATING!!!!!

  • Bill Smith commented  ·   ·  Flag as inappropriate

    At least once a day this happens to me. Cache folder is accessible. Save will work and then all of a sudden will not.
    Overall, InDesign has been more buggy for me post High Sierra (Mac OS) and none of the issues seem to get addressed.

    One the plus side, InDesign has always been good at recovering crashed files and I rarely lose work, but is a time-killer nonetheless and would like it fixed.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Yes. This is pretty frustrating. Especially when I work in InDesign nearly every day and have to deal with files that won't save or open because I get an erroneous error code. (0 or 4)

  • Anonymous commented  ·   ·  Flag as inappropriate

    This is the f****** worst!!

    FIX THIS BUG ADOBE!!!

    We work in fast-pace industries and can't keep wasting our time rebuilding "corrupt" files.

  • brian commented  ·   ·  Flag as inappropriate

    I have the same issue. Have to quit indesign without saving then relaunch indesign and most of my work is saved, but not all recent steps. Several undo levels in the past is the norm. The file is never damaged, despite the error code.

  • Gareth Lind commented  ·   ·  Flag as inappropriate

    I have the same issue. Was about to report this. When I restart ID, it works, but this version seems just as buggy as the last.

  • Anonymous commented  ·   ·  Flag as inappropriate

    With InDesign CC 13.0.1, I cannot create new documents. When I try to create a new document, I get an error message that says, "Cannot create new file. The file 'unknown document' is damaged. Error Code: 0." Image attached.

  • Andrew Eisenhauer commented  ·   ·  Flag as inappropriate

    InDesign will not open any documents because the file is "damaged."

    I cannot open any pre-existing documents nor can I create a new document.

    Thanks

  • Glen Saville commented  ·   ·  Flag as inappropriate

    When I try to start a new file no matter which preset I choose I get an Error Type 0 document is damaged, this bug has been in CC a while, I usually fix it by quitting and restarting InDesign, I suspect it's some kind of caching problem!? Happens in Version 13.0.0.125 & also in versions: 12.1.0.56 & 11.4.1.102 so it's been lurking there a while please fix it soon Adobe, it's a big pan to have to quit when under pressure to get a job done!

Feedback and Knowledge Base