Bug details

Unable to launch Adobe InDesign as you do not have sufficient permissions to access the preferences folders.

I can't even open InDesign anymore, I keep getting an error message that says "Unable to launch Adobe InDesign as you do not have sufficient permissions to access the preferences folders. Ensure that you have appropriate permissions and then restart Adobe InDesign." I've changed permissions on every folder and file to "Read & Write" that I thought would help make it work but nothing is working. I was trying to open the latest version of ID, even undownloaded and tried using CC 2017 to no avail. I need this fixed ASAP.

MacBook Pro (15-inch, 2017)
MacOS High Sierra Version 10.13.3

Please let me know what other information you need.

18 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    stephanie shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    Resolved For the User  ·  AdminRavi Kiran (Admin, Adobe InDesign) responded  · 

    Please follow the following steps to resolve the issue:
    Go to Terminal (Go→Utilities→Terminal.app)
    Execute the following command on terminal to provide permission –
    1. sudo chmod -R 777 /Users/username/Library/Preferences/Adobe\ InDesign
    2. sudo chmod -R 777 /Users/username/Library/Caches/Adobe\ InDesign
    3. sudo chmod -R 777 /Users/username/Library/Application\ Support
    where “username” is the user id with which you are logged in.

    Refer to article for more information – https://support.apple.com/en-us/HT203538

    If the issue is not resolved after following the above steps, drop a mail to santalwa@adobe.com.

    Thanks,
    InDesign Team

    24 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Christine commented  ·   ·  Flag as inappropriate

        Yay Ravi!!! Thank you! I have been having this issue since my employer switched over to the newer InDesign. They thought that it had something to do with an older version of Mac OS (X El Capitan). But, I followed your steps and now not only does it work, I get the credit for figuring it out! Thank you Ravi!

      • Anonymous commented  ·   ·  Flag as inappropriate

        Jan 2019 and I am having this problem on a PC after updating to the 2019 InDesign. How do I fix it on a PC running Windows 10?

      • Timo Kurz commented  ·   ·  Flag as inappropriate

        If you don't have the /Caches/InDesign. Create it and do:
        sudo chmod -R 777 /Users/labuser/Library/Caches/Adobe\ InDesign

        Thats fixed my problem

      • Sam Swenson commented  ·   ·  Flag as inappropriate

        Ravi's solution works. You just need to replace the user's name in each of the directory paths with your user's name (see examples below):
        sudo chmod -R 777 /Users/YOURUSERNAMEHERE/Library/Preferences/Adobe\ InDesign
        sudo chmod -R 777 /Users/YOURUSERNAMEHERE/Library/Caches/Adobe\ InDesign
        sudo chmod -R 777 /Users/YOURUSERNAMEHERE/Library/Application\ Support

      • Anonymous commented  ·   ·  Flag as inappropriate

        This has also worked for me, however, intermittently and on an almost daily basis, the cache permissions automatically revert back to read only. And so then I have to manually go back and change cache permissions every time I need to open InDesign or Illustrator.

        This is a serious bug and really needs to be resolved in the fastest upcoming release of either OSX or Adobe CC or Both!!

      • Faks commented  ·   ·  Flag as inappropriate

        I had the exact same problem.
        I used the Terminal.app to change my folder rights as explained by @Ravi Kiran. Problem, at the step 2 (sudo chmod -R 777 /Users/myUserName/Library/Caches/Adobe\ InDesign) I got this message :

        /Users/myUserName/Library/Caches/Adobe InDesign: No such file or directory

        I don't know why, but the folder Adobe InDesign was missing in my Caches folder of my Library. Luckily for me, I ask a friend (who has the Creative CC too) to send me his own Adobe InDesign folder (/Users/myFriendUserName/Library/Caches/Adobe InDesign). I copy his folder on my computer at the right place (/Users/myUserName/Library/Caches/) and InDesign CC 2018 worked again!

        Voilà!

      • Stephen commented  ·   ·  Flag as inappropriate

        I had the same issue for a few days (24th May, 2018). In that time I tried uninstalling and reinstalling older versions.

        In the end, what got it working was changing the permissions in
        ~/Library/Preferences
        ~/Library/Application Support
        and ~/Library/Caches

      • Adam Fuchs commented  ·   ·  Flag as inappropriate

        I ran into this today (5/2/2018). First of–screw Gatekeeper and High Sierra permissions. I get the theory behind, but don't roll it out until its actually ready.

        Secondly—go into terminal and run:
        cd ~/Library
        then:
        chmod 777 Caches
        chmod 777 Preferences

        Restart your computer and open inDesign.

        NOTE: This process has also worked for me with numerous other programs that don't get along with High Sierra in case you run into others. Always set 777 on Cache (not sure why it gets reset to not 777) and then whatever folder you get the error on.

      • Anonymous commented  ·   ·  Flag as inappropriate

        I'm having the same issue. Have tried deleting preference folders in ~/Library/Preferences and ~/Library/Application Support. No difference.
        Doesn't work. Now what?

        Fix please Adobe.

      • Arielle_current120 commented  ·   ·  Flag as inappropriate

        Same problem. I went to ~/Library/Preferences at cleared those preferences and I don't see anything for Adobe Indesign in ~/Library/Application Support or Caches either (but that's probably because I run CleanMyMac3).

        Been unable to use Indesign for two weeks now, which is unacceptable as a professional designer. Please help me resolve this.

      • MT commented  ·   ·  Flag as inappropriate

        I have a similar if not the same issue. I get the following prompts when i try to open my file.

        This file is already open by another user or another application. This file may be stored on a network server and cannot be open until the other user closes it.

      • summoner2100 commented  ·   ·  Flag as inappropriate

        Had this problem for a couple of my users today (I work in IT).. Going into ~/Library/preferences and ~/Library/Application Support and manually deleting the preference folders for each of the adobe ones. It asked for admin permissions to delete (which it shouldn't in user directory libraries) but when the app re-opened it worked fine.

        This clears your preference setups though.

      • kurt de wit commented  ·   ·  Flag as inappropriate

        have the same problem over here ; Kan Adobe InDesign niet starten omdat u niet genoeg rechten hebt voor toegang tot de mappen met voorkeuren. Controleer of u de juiste rechten hebt en start Adobe InDesign opnieuw. iMac (27-inch, Late 2013) mac OS high Sierra

      • Jeff commented  ·   ·  Flag as inappropriate

        I'm having the same issue! I've tried everything my IT staff has suggested, to no avail. They are just as stumped as I am.

      ← Previous 1

      Feedback and Knowledge Base