Bug details

Proportional Scaling Using Shift Button Not Working

In the 2017.1 release of InDesign, the ability to hold Shift and scale objects proportionally seems to have disappeared. I know for me this is a major functionality problem that is increasing the time I have to spend on current projects. I've checked support forums and others are encountering this problem, but I haven't yet seen a solution.

78 votes
Sign in
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Layne Ransom shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

Hello All,

Thank you for your patience all this while; we really appreciate your support!

Our investigation suggests that one of common reasons for the problem is that certain software (mostly antivirus and other security applications) and browser extensions happen to enable “Secure Keyboard Entry” on Mac machines due to which some keys such as Shift key in this case do not perform the desired action in InDesign.

For now I request you to follow the below provided KB doc for the quick workaround of the problem.

In the comments section many of the users have confirmed that disabling Webroot SecureAnywhere (a security app) has resolved the issue for them. Please note that, the problem may not be related to a particular software; there could be a different application or antivirus which might be causing the problem by enabling Secure Keyboard Entry on Mac.

Abhinav Kaushik
InDesign Team


Sign in
Sign in with: facebook google
Signed in as (Sign out)
  • Leanna Hanson commented  ·   ·  Flag as inappropriate

    I do not have Webroot or other antivirus software installed. This is a big problem. Even when the "constrain proportions for scaling" icon is selected and I hold down the shift key, it does not work. Please fix asap.

  • Anonymous commented  ·   ·  Flag as inappropriate

    I am having same issue in Photoshop, do not have Webroot. Please fix, this is a mess.

  • Bryan commented  ·   ·  Flag as inappropriate

    When I am trying to scale a placed image using Shift+Option+Command on my Mac running OS Mojave, InDesign is only allowing me to scale the window, cropping the image as opposed to proportionately scaling the image as it has always done in the past. I've tried to quit Webroot SecureAnywhere app and restart InDesign and have renamed Library files as have been described and advised in other posts without success. All other posts I've seen with similar issues are only mentioning that the Shift key is not working properly (due to the change in the way that InDesign handles scaling in this latest version). My issue seems to be different.

  • Aaron commented  ·   ·  Flag as inappropriate

    If you have Webroot installed and are experiencing this problem on a Mac, click the Webroot icon in the header bar at the top of the screen. Click "Pause secure keyboard entry" from the dropdown menu and it should provide a quick fix to the problem. It worked for me, I hope this helps!

  • Paul Santana commented  ·   ·  Flag as inappropriate

    I have been a loyal user for many years. This is a big issue. That shortcut and functionality allowed the designer to be fast and efficient. This will slow me down... annoying!!!!!! stupid, just simply stupid. I wonder why this was dropped or if it's just something that was missed?

  • Sara Hubbard commented  ·   ·  Flag as inappropriate

    This is STILL not working. I do not have Webroot installed, your solution does not fix this problem. It works in Photoshop and Illustrator, but not InDesign. This is such a core functionality of InDesign, it's making it very difficult to use this software at all.

  • Alex Strange commented  ·   ·  Flag as inappropriate

    please help with this issue adobe ^^ this has been happening BOTH in the 2018 and 2019 versions and it's making using the program impossible!
    the object won't hold it's proportions while rescaling

  • Anonymous commented  ·   ·  Flag as inappropriate

    Well, good to see it's a recent issue. For the record, I don't have any software of that sort installed. Running into this issue with Photoshop since 2019 update.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Never had this issue before...just updated to ID CC2019 and clicking shift-scale works up to a certain point. When enlarging an image, scaling remains proportional until mouse reaches a few cm above document bounds (and into the canvas), at which point I lose proportion control.

    Note: I tried removing "PSUserConfig.txt" from my PS CC13 prefs folder (which I installed yesterday to bring back shift key behavior in Photoshop) and restarting, but problem remains.

  • Robert Watson commented  ·   ·  Flag as inappropriate

    Yeah.... it seems like you just need to drag for proportional scaling??? If you hold shit or option is seems to want to do smart scaling and it snaps to objects?

  • Jessica commented  ·   ·  Flag as inappropriate

    So I guess the default is to scale proportionately now. It works fine if you don't hit shift. Now we must all break this habit we have been using for years.

  • eg commented  ·   ·  Flag as inappropriate

    same problem here in Photoshop Windows machine. Shift doesn't constrain proportions after 2019 update

  • Emily Phelan commented  ·   ·  Flag as inappropriate

    This makes me never want to update! Same problem on PC. No webroot. Caps lock is now constrain for some reason. Really obnoxious.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Fix this! Iam in my project week and I NEED the program the most atm. Pleaaase fix it!

Feedback and Knowledge Base