Bug details

InDesign 14.0. freezes after opening

After opening InDesign 14.0 I can open project. But as soon a leave first running screen with InDesign, work on 2nd Screen or even just opening explorer or browse in the internet, InDesign 14.0 is freezing. I cannot even close it. I have to restart the system. In fact I cannot work with it. I have to run 13.1 (2018) to work with ID.
I am working with Desktop PC and Win10

27 votes
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Kathrin Federer shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

Hello All,

Thank you for your patience all this while.
This issue is now fixed in the latest update (Id 14.0.1) of InDesign CC.
If you are unable to see the update notification yet, open the menu (three dots) from the top-right of Creative Cloud desktop application and click on ‘Check For App Updates’.

Once the update button is shown against InDesign CC, click on the button to update your InDesign to Id 14.0.1 for the fix of the issue.
Do let us know in the comments, if you face any problem with the new update.

List of fixed issues can be found at: helpx.adobe.com/indesign/kb/fixed-issues.html

Regards,
InDesign Team

25 comments

Comments are closed
  • Mer commented  ·   ·  Flag as inappropriate

    I had to call customer support twice yesterday for this. The second time they informed me that it's a glitch with external drives. Once I saved all the linked files I needed from my ED and disconnected it, indd went back to working fine.

  • Steve commented  ·   ·  Flag as inappropriate

    Thank you for your non-answer, Adobe.

    It's been 4 months and InDesign still hasn't been fixed!

    Ignoring the issue won't make it go away....but it may make Adobe users go away.

  • Steve commented  ·   ·  Flag as inappropriate

    Abhinav – any ETA on a fix.

    14.0.1 is definitely not the answer.

    Thanks!

  • Anonymous commented  ·   ·  Flag as inappropriate

    Also still having this issue. V frustrating that this has been going on for months.

  • Steve commented  ·   ·  Flag as inappropriate

    ID 14.0.1 is STILL freezing and crashing. I can't count how many times I've done clean installs – not to mention the money I've lost putzing around with this less-than-consistent software. What a major disappointment! Back to ID 2018 for me....

  • Chris commented  ·   ·  Flag as inappropriate

    InDesign 14.01 keeps crashing. It worked up until a few hours ago. I tried uninstalling and reinstalling still same issue. Really frustrating as I have a time-sensitive project due by end of day. I'm running Mojave a few weeks ago and everything has been working up until now. Any help would be really really appreciated!! Thanks!!

  • Rosanna commented  ·   ·  Flag as inappropriate

    Hi, I uploaded the latest fix-up version 14.01 and now when I work on an indesign document after a while I can't get any response from the editing tools. e.g. I select a text box and try to add effects and then it either doesn't take effect or I preview and cancel (if I don't like the effect) but when I select again the effect is still there. This is causing a lot of time wastage with my designs and deadlines. I had to go back to 2018 version to to able to edit correctly. I think it was OK after the first fix-up but not the second. Not sure what to do now. Thanks, Rosanna

  • Rosanna commented  ·   ·  Flag as inappropriate

    I downloaded the update a couple of days ago and it has fixed the problems I was having with the text tool and freezing. Thank you, Rosanna

  • Anonymous commented  ·   ·  Flag as inappropriate

    Have simular problem, not as bad. But Indesign freezes for a some time. After that I am able to work.

  • Anonymous commented  ·   ·  Flag as inappropriate

    I am having this problem with ALL documents in ID 2019, not just a specific document. ID 2018 works fine on all those documents.

  • Anonymous commented  ·   ·  Flag as inappropriate

    We have exactly this problem: multiple users, on different PC's, with different files. Happens every time InDesign is opened.

    InDesign CC 2019: v 14.0
    Windows 10: v 1803 (OS Build 17134.345)

  • Matthew Pepping commented  ·   ·  Flag as inappropriate

    Right after starting ID, when opening the first document, the toolbox freezes. for 15 to 20 seconds. Other menus are accessible.

  • Anonymous commented  ·   ·  Flag as inappropriate

    I'm running mojave 10.14 on mac pro. No issues with Indesign 2018. It happens with different documents. Just spinning beach ball after a few seconds.

  • Telisha commented  ·   ·  Flag as inappropriate

    I believe I am having the same or similar issue.

    I recently updated to InDesign 2019 and had no problem using it last week.
    Today it is not opening properly, taking around 10 minutes to open a file, then freezes the second I try to do anything in a text box.

    It has occurred with every file I've tried, multiple times.
    I have also tried ending all InDesign processes and restarting my computer.

    InDesign CC 2019: v 14.0
    Windows 10: v 1803

  • Aaron Winters commented  ·   ·  Flag as inappropriate

    I upgraded to Mojave this morning. InDesign now completes launch and all menus appear to be active. I can open documents, but that is literally all I can do. No selection, can't change tools.

    Although I had already restarted twice since the update, I tried again and it appears as though InDesign does in fact work again.

    A little scary having to take on an OS upgrade so soon after announced, but seems to have solved this issue for now.

  • Dale Nibbe commented  ·   ·  Flag as inappropriate

    Are you all updated to the latest Mac OS? I've tried everything on my iMac running macOS Sierra 10.2.6 and nothing works. Deleted previous versions of ID and all preferences, reinstalled the latest version of InDesign after restarting my iMac and still nothing worked. Do I have to upgrade to the latest macOS for this to finally work?

  • Aaron Winters commented  ·   ·  Flag as inappropriate

    I also just cleared all prefs and caches as suggested and now InD locks as before, but with no 'recent doc', just a blank workspace frame. Completely locked out of app now.

← Previous 1

Feedback and Knowledge Base