Bug details

Fehlercode 4/Errorcode 4 for not damaged documents

1. Adobe Indesin CC 13.01
After the last Update of Indesign time by time suddenly Indesign report a damaged file if you try to open any InDesign-Document.

Everytime after restarting the Mac everything is good and I'm fortunally able to open all o these documents.

Sometimes restarting Indesign helps, but not always.

The last 3 days it happens much to often und it nervs.

52 votes
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Tom Reuter shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

We’ve been able to identify one scenario in which the cache folder is not accessible while InDesign is launched, resulting in the issue. The issue seems to be specific to MAC OS.

We have released an update for InDesign CC2019 (v 14.0.2) which contains some stability fixes. If you are not already on 14.0.2, then we recommend you to update to latest version.

If you still encounter the issue again, try to access the location “/Users//Library/Caches/Adobe InDesign/Version/14.0/en_US/InDesign Recovery/*” and create a file in the directory.

Workaround – Quit & relaunch the application, Cache folder gets created and the problem is resolved.

-InDesign Team

61 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Peter Maertens commented  ·   ·  Flag as inappropriate

    Foutcode, kan bestand niet opslaan.
    Werk met 14.0.1
    Graag uw hulp.
    Heb alles reeds opnieuw geïnstalleerd, en is op al mijn computers zo.

  • Sanyam Talwar commented  ·   ·  Flag as inappropriate

    Please submit the crash report to us.
    (Guidelines to submit crash are available at https://helpx.adobe.com/indesign/kb/submit-crash-reports.html)

    Also, please send the following information to santalwa@adobe.com :

    • Is the issue related to a specific document(s)/asset(s)? If yes, can you please share the document(s)/asset(s) with us?
    • Does trashing InDesign Preferences and Cache help resolve the issue? Please take a backup of the same before trashing them.

    Adobe InDesign team

  • Daniel Doller commented  ·   ·  Flag as inappropriate

    I forgot to say, I use InDesign CC2019, 14.0.1 on an 27" 5K iMac 2017, 4,2 GHz i7, Radeon Pro 580 8GB, 32 GB RAM, macOS High Sierra 10.13.6

  • Daniel Doller commented  ·   ·  Flag as inappropriate

    If I save a file with "Save as" local on my HDD or an AFP File-Server sometimes InDesign CC2019 crashes and deletes the file. Only the IDLK-File is still there. If I start InDesign again, it says, that it can't restore the file. This happens on all 13 iMacs, that we are working with. I already deleted all preference ans set InDesign back to factory settings, but it didn't help.

    This Bug appears only after we upgraded from CC2017 to C2019. With CS3-CC2017 there were no problem with the "Save as" function.

    Please fix this horrible bug.

  • Mike_A commented  ·   ·  Flag as inappropriate

    Dear Santalwa, InDesign Team
    I am the one who originated this query. It has recurred several times. Shutting down and restarting has solved the issue for me. I have had several comments from other users experiencing the same thing but no response from Adobe until now. Replying to your
    1) Mac OS High Sierra 10.13.06
    2) Not sure I understand what you mean here??
    3) Yes, I do run Time Machine which is of course a standard Mac utility.

  • Maite commented  ·   ·  Flag as inappropriate

    Hello,

    I'm facing the same issue. Already sent you the corrupted file. How long do you usually take to answer or recover this kind of file ? Thanks for your precious help.

  • Maite commented  ·   ·  Flag as inappropriate

    Hello,

    I'm facing the same issue. Already sent you the corrupted file. How long do you usually take to answer or recover this kind of file ? Thanks for your precious help.

  • GORGEOUS HQ commented  ·   ·  Flag as inappropriate

    Honestly, this has been happening to me for years. I've just learned to deal with it hoping that future versions of ID would solve the issue. It ALWAYS happens though. Every time I use ID and I've had it running for a few hours with multiple tabs/projects open, the error will pop up when I try to open a new file. Closing and restarting the app has always fixed the issue but it's clearly beyond annoying. Especially to be dealing with it as long as I have. 2014 is probably when I first started noticing it so it has zero to do with High Sierra.

    Machines affected: 2017 MacBook Pro Retina with TouchBar i7 16GB 512GB SSD, 2018 MacBook i7 16GB 512GB SSD, 2014 MacBook Air i7 8GB 512GB SSD, 2011 MacBook Air i7 8GB 256GB SSD
    MacOS versions affected: OS X Mavericks, OS X Yosemite, OS X El Capitan, macOS Sierra, and macOS High Sierra

  • Mike_A commented  ·   ·  Flag as inappropriate

    ALL of my InDesign files are now showing The file is damaged - Error Code 4 . They were opening without any issue about three days ago and I have not made changes/ updated software since. Why is this happening?

  • Anonymous commented  ·   ·  Flag as inappropriate

    Happening to me as well. Mid July, still issues. Paying for CC, using ID professionally, need this resolved right away.

  • Frank Ameneiro commented  ·   ·  Flag as inappropriate

    Indesign 13.1 Error 4, stops me from saving or opening files. I have to quit Indesign 13.1 before I can proceed. Then it seems to work. I have deleted the cache as suggested countless times, it still happens. I have a feeling it's something to do with Illustrator 22.1, when I open that to work on a file and then quit it. It is then that I seem to get the error code 4 in indesign. Can you please advise.

  • Anthony commented  ·   ·  Flag as inappropriate

    Sometimes when I already have Indesign open it wont let me open more files. It displays this message:

    Cannot open "".
    The File is damaged.

    I completely restart Indesign and then I am apple to open the file it said was damaged. How about this latest update on InDesign was damaged. Please Fix!

  • Oskar Oades commented  ·   ·  Flag as inappropriate

    Get error 4 sporadically, usually when opening documents made with older versions of indesign through Indesign. I find that quitting indesign then opening the file directly from its folder rather than through indesign usually sorts the issue however this doesn't work if i want to open multiple files at a time. InDesign also crashes when I try to close the documents.

    I use a MacBook Pro Retina 15'' Mid 2015, Operating High Sierra V10.13.4 and the most recent update of InDesign

  • Kate Paullin commented  ·   ·  Flag as inappropriate

    I don't use InDesign very often, so today is very possibly the first day I've used it since updating to CC2018 and now I'm having this issue too. Adobe seems unwilling to acknowledge it's a bug in their app and not flaws in thousands of individual INDD files. It happened to a file while I had it open, which crashed InDesign.

  • Jason commented  ·   ·  Flag as inappropriate

    InDesign version 13.1... occasionally I cannot save file or open an existing file due to an error message that tells me the file is damaged. If I quit InDesign and re-open file, everything is fine. This becomes a problem if I don't save often or if auto-save is not up-to-date because work may be lost and unrecoverable. I cannot reproduce this problem. Just like random Mac OS crashes, this InDesign bug appears without warning at random times. I have experienced this issue for several months now with more than one update.

  • Dean Cook commented  ·   ·  Flag as inappropriate

    Phew! Resetting preferences (Mac: Shift+Control+Option+Command) as you open InDesign has helped but, for the first time since CS2, I cannot trust the program that file integrity will remain. Still doesn't resolve one magazine that cannot be opened due to a 'database error'.

  • Dean Cook commented  ·   ·  Flag as inappropriate

    ...and five minutes later. YES, it has happened to me too! (Error code 4). Two separate systems happening at identical times. What the hell.

  • Dean Cook commented  ·   ·  Flag as inappropriate

    My colleague has encountered two documents encountering error code 4. Both magazines nearing completion. We are FURIOUS and concerned the work is lost. We have backed-up, but even an old back-up file is doing the same. All files are local. What is the solution please Adobe? I am now concerned my system will do the same. We're both running Mac OS X High Sierra, 10.13.4, InDesign CC 13.0.1.

← Previous 1 3 4

Feedback and Knowledge Base