Bug details

png transparent background showing black

Importing this icon and the transparent background is showing as black in current inDesign CC. Didn't have issues with similar icons from same site.

8 votes
Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)

We’ll send you updates on this idea

Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

11 comments

Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
Submitting...
  • Jieru Xu commented  ·   ·  Flag as inappropriate

    (1) "-edit-->preferences-->appearance to black-->changed output to print all black accurately"
    This didn't work.
    (2) "placed a black image over background instead of filling the background with the 'rich black swatch'"
    This didn't work, either.
    (3) emerged a new transparent layer and the original image in Photoshop, and then dragged to InDesign
    Didn;t work either.

    I think I'm totally crazy.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Just started having this problem today. Solved it with Chip's edit to preferences.

  • Chip Free commented  ·   ·  Flag as inappropriate

    After exporting to pdf from Indesign to Acrobat the transparent background around image prints a darker black than the surrounding black background. I've spent tons of time tweaking settings and reading post and could not resolve the problem. I was able to print correctly from indesign once I changed:

    -edit-->preferences-->appearance to black-->changed output to print all black accurately

    However, from indesign, I couldn't change my printer setting to print 2 to a page and 2 sided so I still needed to print from acrobat. I changed tons of settings in acrobat thinking it had to do with rich black issues or compression issues etc.

    I did find a work around that may help to avoid the problem. I went back to indesign and placed a black image over background instead of filling the background with the 'rich black swatch'. I created the black image in fireworks as .png.

    When I exported this time, the blacks matched. Maybe someone knows how to fix without using an image but at least this helped get the job done.

    Chip
    -

  • mastretrixdj commented  ·   ·  Flag as inappropriate

    Make sure your image is not 8 bit, you may be required to convert it to 16 bit or higher. When exporting your png file from photoshop or your favourite image editor. make sure to uncheck "Smaller file size (8 bit)"

  • Nuri Pazol commented  ·   ·  Flag as inappropriate

    I took Anasuiya Gupta's advice and added a new blank, transparent later below, and then merged the two layers, then saved as she suggested. Worked great. Consider her suggestion the current solution.

  • Scott commented  ·   ·  Flag as inappropriate

    Hi Anasuita,

    That's not a good fix, it a patch fix at best.

    I've been having the same problem and it's happening to 100's of images. I can't even open them in photoshop because I get an error message and if I could that's so time-consuming.

    I've been trying to work on a data merge project for a couple of days now and it's frustrating me to no end. I've switched from PNGs to GIFs to work around the black backgrounds, but now the GIF files corrupt at random. Leaving big black streaks.

  • Chris commented  ·   ·  Flag as inappropriate

    I have the same problem. importing any transparent PNG shows black at the transparent part!!! Please fix it adobe!

    indesign 2018 13.0.1

Feedback and Knowledge Base