Bug details

InDesign CC 2018 stalls to a spinning beachball right after opening for a brief time

On first opening InDesign in Sierra 10.2.4, after a couple of seconds of not taking any action, InDesign stalls briefly—about 3 to 4 seconds—not allowing any new action during that time. There is just a spinning beachball. I can postpone the beachball by immediately opening a menu; but after mousing away from the menu the beachball comes back. Not sure if it is trying to load something, but I currently don't have any extra extensions installed. I tried resetting preferences and removing all user install scripts, but it still did it. It's consistent every time I open the new version. I did not carry forward preferences from previous versions. My CC library is synced and not showing any connection issues. Not a major bug, sort of the equivalent of tripping over the same spot of carpet whenever you enter into a room.

12 votes
Sign in
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Ben Scribble shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

We are currently investigating the issue as the issue is not reproducible inhouse. We have sent mails to most of the folks and received following responses:
• The issue got resolved automatically.
• The issue immediately vanished when Unchecking Creative Cloud synchronization.
• Upgrade to OS 10.13.6 resolved the issue
• The issue got resolved after turning off TypeKit sync

InDesign Team


Sign in
Sign in with: facebook google
Signed in as (Sign out)
  • Melissa commented  ·   ·  Flag as inappropriate

    I have the skinny wheel issue as well. Just had the Mac wiped and it is better but still happens. I think the problem is because I am working on a file that has a lot of photos. Maybe I need more ram to run InDesign CC18??? What do you reccommend? I have 16GB ram and 1TB HD space on iMac 3.4 GHz Intel core i5 Sierra. I did have High Sierra before the computer wipe. IT recommended I don't go to Mahave because they said there were even more issues. What is your suggestion? I think it is due to the GPU performance trying to render all the photos. But I need all the photos.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Now I have the same problem! After nearly every click the beachball appears. Annoying! Does anyone have a solution? The trick of Simon works also for me. But this is not really a sollution. I have to copy & paste Text from a Word Doc with 120 Sites and every time I change the a programm via CMD+TAB the Beachball apperas. I have to use CMD+TAB more than 1.000 times.

  • Ben commented  ·   ·  Flag as inappropriate

    Totally agree with all the comments here. What a joke. They keep putting the subscription fee up for Creative Cloud yet their products don't work anywhere near to the level that would be considered acceptable to professionals. In Design has been rendered almost useless. FIX IT!

  • Anonymous commented  ·   ·  Flag as inappropriate

    Have been told InDesign 2019 does not support GPU Performance on pre-retina display iMacs - this is mental. Illustrator and Photoshop both support GPU Performance on older iMacs. This is a crazy situation brought on by Adobe - thousands of designers on older Macs are now being seriously penalised. This is not acceptable when we pay a lot of money for our software license. InDesign is my livelyhood and I am now spending hours during the course of a day watching a spinning beach ball - totally unacceptable Adobe.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Seriously, why did the older versions work better than new? This spinning beach ball is driving me crazy!

  • Ihat Eadobe commented  ·   ·  Flag as inappropriate

    Same issue here since ID CC 2018-don't-remember-what-version-it-suddenly-started-now-it-won't-go-away HAVE TO RESTART ID EVERY TIME JESUS CHRIST DO YOU FCKIN JOB ADOBES!!!

  • Lorenzo Norfini commented  ·   ·  Flag as inappropriate

    I pay a considerably high fee for the usage of your products. I'm a professional that has to use his software whenever he needs it. It's since this morning that I can't use InDesign due to some mysterious reason (yesterday I had no problem). I can't neither move the cursor without that spinning ball keep rotating for tens of seconds uselessly. I HAVE TO WORK!!! So tell me what I have to do in order to make your software working again. Mac OS 10.3.6 / InDesign CC 2018 (but it is the same with InDesign CC 2019) / Suitcase Fusion 20.0.1)

  • Anonymous commented  ·   ·  Flag as inappropriate

    Any input, no matter how (un)intensive, first requires a beachball moment. Hold spacebar for the hand to move around my document, wait for the pretty ball first. You want to select that text box? Beach Ball. Curson sitting idle? Beach Ball. It will also beach ball if I simply HOVER OVER THE TOOLS.

    Why have synchronization if it causes problems? No, i don't want to uncheck anything. No, I don't want to delete and reinstall prefs. I want the software TO FUNCTION.

  • Anonymous commented  ·   ·  Flag as inappropriate

    September 2018 and a brand new mac and I am wasting so much time using your cc saas. This is really a ridiculous situation and one which you should be solving - not suggesting useless workarounds. Your software should work - we're paying for it you know!

  • Anonymous commented  ·   ·  Flag as inappropriate

    Same issue here, drives me completely crazy. Typekit and Cloud sync disabled, issue not resolved.
    I'm paying so much money for this software........ really don't get it.

    Running macOS 10.13.6, InDesign 13.1

  • Simon commented  ·   ·  Flag as inappropriate

    Same problem and Ravi Kiran your suggestions does not help me.
    The issue I have is that every time I CMD+TAB out of Indesign and to another application and then back to Indesign that's when I get a spinning beach ball. First a couple of seconds wait, then the ball appears for about 5 seconds. I think there's something wrong regarding fonts but I can't confirm it.

    Also - A slight workaround for this problem is to open up a dialog window for example Go to page (CMD+J) before you tab out of Indesign. When going back to Indesign just hit the cancel button on the window and there is no spinning beach ball. However it's still way too annoying. With this info you should be able to fix this problem Adobe.

    It's unusable and cannot work this way.

  • Anonymous commented  ·   ·  Flag as inappropriate

    I have the same problem, I get the beach ball of death for about 5-10 seconds every time I attempt to edit any text or select an object. Grrr!!

  • Anonymous commented  ·   ·  Flag as inappropriate

    Spinning ball for no reason - adding 50 percent more time to every project and 1000% frustration

  • Eli commented  ·   ·  Flag as inappropriate

    Same problem. Spinning when I click on any one object, spinning when I mouse over a tool, Spinning every few secs. Its un-useable! Tried every suggestion there is out there and the spinning ball comes back every time! This is a dire fundamental issue. Adobe please at least acknowledge and tell us you are owning on this fix.

  • Marc commented  ·   ·  Flag as inappropriate

    Spinning, spinning, and no answers!! No obvious reason for it. Been happy with Adobe products for past 14 years, but this is frustrating and pretty much unworkable. It is hampering work efficiencies, costing us valuable staff time and delays on design/layout jobs. In short, it's costing us money.
    Adobe team, if you bother to read this --> FIX IT!!!!

  • Lora commented  ·   ·  Flag as inappropriate

    All our files are on a server. I have turned off almost everything I can to make it run faster. I'm NOT going to do a soft reboot just to get a program to run, when everything else runs fine. We're already waiting to jump ship. ID will go the way of Quark if something doesn't change soon

← Previous 1

Feedback and Knowledge Base