Bug details

Placed ICML files do not appear in the Assignments panel

Placed InCopy ICML files should appear in the Assignments panel. They do not. This is under InDesign CC2018.1.

The only step needed to reproduce this is to create an InCopy file. Save it and then place in InDesign.

11 votes
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Bob Levine shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

Hello All,

Thank you for your support. The issue is now fixed in the latest update of InDesign.
Please upgrade to the new InDesign 14.0 from your Creative Cloud Application.

If you are unable to see the update yet, click on the menu (three dots) on the top right corner of Creative cloud app and click on “Check for App Updates”.

Let us know your feedback in the comment section.

Thanks,
Abhinav Kaushik
InDesign Team

11 comments

Comments are closed
  • Andy Taylor commented  ·   ·  Flag as inappropriate

    I still have this issue even after everything is updated.
    If I draw a text box FIRST, the IC document, whether dragged or placed into that text box, has a high chance of not showing up in the assignments panel.

    Workarounds:
    Draw the text box(es) first, place or drag-and-drop the IC document into the box, then select all text boxes for that story, cut, and paste in place.
    OR
    Place/drag-and-drop the InCopy document directly on the page.

  • Karen Walsh commented  ·   ·  Flag as inappropriate

    I too would like a resolution as soon as possible. We just upgraded our entire dept over this past weekend and we use an InDesign / InCopy workflow for our catalogs and had to revert everyone to 2017 so we could release our catalog. I did a test of a 2018 InDesign file and created a new text box and placed 2018 InCopy asset in the file. The asset name didn't appear in the assignments panel but I could see the globe symbol on the text box indicating it was an Incopy asset and when I hovered over the box the asset name appeared. If I double-click on the Box it asked me if I want to check it out and I do so I can edit it. The only way to check it back in is to choose "check in all" from the Assignment panel. No asset name appears. I option-dragged 3 copies of the text box in the InDesign file and for each copy the name did appear in the Assignment panel but the original did not.

  • Brian commented  ·   ·  Flag as inappropriate

    I have 30 Indesign and Incopy users at my publishing company that all follow one work flow and this issue is a huge monkey wrench thrown into the mix. Is this fix becoming available anytime in the very near future? I've downloaded the Prerelease for Indesign CC 2019 and that did work fixing the assignment issues but it's only in Free Trial mode. What can I do to fix this for my other 30 users?

    Thanks

  • Patrick commented  ·   ·  Flag as inappropriate

    This seems to be a problem since April of 2018. It is now almost August. This needs to be fixed tomorrow.

  • RY commented  ·   ·  Flag as inappropriate

    "Sorry!
    This link is no longer valid. Please contact the Program Admin.

    Contact Adobe Prerelease Support for support."

  • Lisa commented  ·   ·  Flag as inappropriate

    Same problem for me as well, since the latest InDesign update. Thanks for being on the hunt to fix this!

Feedback and Knowledge Base