Bug details

World-Ready Composer Is messing up the kerning in Latin fonts

I have reported a variation of this—back with CS6—but it seems not to have been fixed. I assume it's a bug, but if someone can enlighten me about what I might be doing wrong and how I can fix this, I'd appreciate it.

I often work on books that include Arabic and Hebrew words and phrases in the middle of English text. They only way to get the Arabic ligatures to form is to use one of the World Ready composers. When I do that, though, the kerning around some English characters often—but not always—is affected. I have tried turning on and off various settings—justification settings, kashidas, etc.—and their effect seems to be random. Sometimes the changes fix the problem until the page redraws, sometimes the errant kerning is corrected in one location but shows up in another location, sometimes nothing happens at all. I'm attaching two screen captures of a book that I have in production now with the word "economics" selected in each. In the shot with the World-Ready Paragraph Composer active, you can see the extra kerning between the "e" and the "c." In the shot with the WRPC deactivated, the word looks as it should.

Is this a bug? If not, what am I doing wrong? If it is, when might we expect a fix. Unfortunately, I have a deadline on this project now and can't see any reasonable way to fix this. Thanks for considering this problem.

13 votes
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Matthew Williams shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

8 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Martin Fischer commented  ·   ·  Flag as inappropriate

    This serious bug is not yet solved in InDesign CS 2019:
    <https://www.dropbox.com/s/cx39ktwpz51q1cq/cp_2019-03-18_01-02-51_PM2.png?dl=0>

    I cannot remember this bug in InDesign ME up to CS5, developed by winsoft.fr.

    To prevent from this bug I still have to typeset books and magazines in InDesign CS4(!).
    It's a question of time that the old iMac with the old OS (Yosemite) stops running and doing this job.

    Please solve this annoying bug in any time soon.

    Regards
    Martin

  • Uwe Laubender commented  ·   ·  Flag as inappropriate

    "When will Adobe address this."
    Since this bug report is labeled with "NEED MORE INFO" I suggest, that everyone who is affected will join InDesign Prerelease and providing documents where the bug is visible there. Unfortunately we cannot upload samples or screenshots while commenting here…

    Also note this new thread at Adobe InDesign Forum:

    RTL + LTR lang in one paragraph with justification
    annahayat Mar 17, 2019

    https://forums.adobe.com/thread/2605107

    Regards,
    Uwe Laubender
    (ACP)

  • Scott Keeney commented  ·   ·  Flag as inappropriate

    This is a serious bug that has been evident for years and still is present in CC2019. When will Adobe address this.

  • Matthew Williams commented  ·   ·  Flag as inappropriate

    Hello Uwe

    Just getting back to this after being overwhelmed with work. Thanks for the links. I'm relieved to know that other people are having the same problem, but I'm disappointed that Adobe seems not to care.

    I have done some more testing by changing preferences, changing paragraph settings, changing character settings, monkeying with saving memory, changing display performance—all to no avail. I too at one time thought that the discretionary line break triggers the bug, but after my latest testing, I'm pretty confident that it does not. Like one of the posters in the threads you provided, I am convinced the that bug is a recomposition problem. InDesign is simply giving up before it finishes composing the text.

    Incomplete recomposition seems to be the underlying cause of two additional bugs that I have reported: Left indents at the top of a page are sometimes not honored until you force InDesign to recompose all stories, and preferences for rules above split footnotes are sometimes not honored after the footnote flow is changed until you open up the footnotes options dialog and change the rule settings, which seems to cause InDesign to reevaluate the treatment of all of the footnotes in the document.

    About half of the books I typeset now have Hebrew or Arabic in them, and this bug is just so frustrating. If there were a viable workaround, it wouldn't be so bad, but there's just nothing effective. I have tried converting the Hebrew and Arabic to outlines, but as another poster pointed out, where the text includes a Hebrew or Arabic phrase—vs. an isolated word—this can create more serious problems, so I've abandoned that workaround.

    I hope that Adobe eventually decides to fix errors in the existing version of the program before focusing their attention on new features. I finally caved in to the subscription model (which I still detest) mostly because I was hoping that they would update the program with bug fixes on a monthly basis and would eventually fix this one. Sigh.

    Anyway, thanks again. I'll keep trying to find a fix as time allows.

    m.

  • Uwe Laubender commented  ·   ·  Flag as inappropriate

    Hi Matthew,
    at least for me and some others this is a known bug we already see in earlier versions of InDesign. I have some samples with e.g. CS6 8.1.0.

    See this discussion in German at hilfdirselbst.ch where Martin Fischer is seeing the issue:
    https://www.hilfdirselbst.ch/foren/Globaler_Adobe_Absatzsetzer%3A_unerw%FCnschte_Spationierungen_an_zuf%E4lligen_Stellen_P551491.html#551491

    Or at the same site this one here:
    https://www.hilfdirselbst.ch/foren/Hebr%E4ische_Buchstaben_laufen_verkehrt_herum_P539208.html#539208

    Also did a crosslink to this report here.

    Thanks,
    Uwe Laubender
    ( ACP )

  • Matthew Williams commented  ·   ·  Flag as inappropriate

    Still nothing more than a month later. Not even an acknowledgment. What a shame. The only solution I have available right now is to convert the Hebrew and Arabic to outlines, turn off World-Ready Paragraph Composer, and hope no one has any edits to the Hebrew or Arabic or to the English text that might cause the Hebrew or Arabic to line break. This is not a nuisance or a "wouldn't it be nice if" report. This is a major behavior problem when setting mixed-direction text, but apparently, Adobe can't be bothered. It's like I'm reliving my Quark days. Sigh.

Feedback and Knowledge Base