Bug details

Indesign CC 2019 14.0.1 xmp-information for images cannot be copied

1: Indesign 14.0.1
2: open any link details for any placed image/XMP-information
3: I want to copy text from this window to clipboard (like credit-information). This was possible in Indesign 2015.
4: it is not possible to copy text.

14 votes
Sign in
Sign in with: Facebook Google
Signed in as (Sign out)

We’ll send you updates on this idea

Thomas Happ shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

Hello All,

The fix for this issue is now available in the beta builds of InDesign. You can download the latest beta build from Download section of InDesign Prerelease portal.

1. Go to https://www.adobeprerelease.com
2. Log in with your Adobe Id.
3. Once logged in, search for “InDesign CC Prerelease” program in the list.
4. Click on the program to join the same.
5. You can now download the build (15.0) from “Builds and Plugins” section on the page.
6. The steps for installing the build can be found in the release notes


Sign in
Sign in with: Facebook Google
Signed in as (Sign out)
  • Susan Bauer Lee commented  ·   ·  Flag as inappropriate

    I'm having this same problem. I realize that I could generate captions, but that's only if the artist has put their information/credit in the correct place, if at all. Either way, I still have to open the XMP panel to see if the info is there, what box it's actually in, then set up captions (or image credit), then generate caption, then put it where I'd actually like for it to go. There's also "Reveal in Bridge" workaround, but that takes me out of my workflow. Either way, it's a giant pain **********, when previously it was so much simpler to open the XMP panel and copy/paste. Please bring that back to InDesign. Please.

  • Thomas Happ commented  ·   ·  Flag as inappropriate

    I have another work around: I think it´s called "add description" in English (I have a German version).
    Select an image, go to object menu, look for something like "customise description". You can select from the xmp information here. After customizing I added a short key (ctrl-B) for "add static description".
    This works fine for me and is much faster than copy paste.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Same problem here. And it's a serious problem when you have to place credits for hundreds of photos in a book. Why you did this?

  • Thomas Happ commented  ·   ·  Flag as inappropriate

    Hi Mhast - the problem is: everything is locked in that window except the RAW-DATA.
    It does not matter if the fields are gey or white.

  • Mhast commented  ·   ·  Flag as inappropriate

    So since 14.0.1 the behaviour seems to have changed. You're now not able to use the XMP File Information command from the Links panel for any file type that I've tested... (It's now also hidden away under the hamburger menu rather than right click, and under a subfolder called 'Utilities' - but sits permanently greyed out so far as I can tell). Tested out on Windows and Mac.

  • Mhast commented  ·   ·  Flag as inappropriate

    Hi Thomas - your screenshot illustrates the problem. If people haven't used the copyright field - and usually they won't, they'll use the author field - then you're stuck, as the greyed out fields are impervious to copying data from them.

  • Mhast commented  ·   ·  Flag as inappropriate

    Have exactly this issue - we use it loads for grabbing copyright information when laying out our magazines. There'a (much slower) work around - in that you can reveal in bridge and then open the XMP info from there, but it's impeded by having to wait for Bridge to switch to the folder and build the thumbnail cache.

    Was working right up until InDesign CC 2018.

Feedback and Knowledge Base