Bug details

Clicking document-installed font from font list gives error to "activate font" and doesn't change font.

InDesign 14.0 on Windows 10 x64

I just upgraded to InDesign 14.0, and there appears to be a bug when clicking a document-installed font from the font list. The font list gives an error message to "Click 'Activate' button to activate fonts" and the text frame keeps the existing font, instead of changing to the new font.

Expected result:
The expected result would be the same behavior as InDesign 13.1, where you could click a document-installed font from the font list, and the text frame would update to the newly selected font.

Actual result:
In InDesign 14.0, clicking a document-installed font from the font list gives an error message to "Click 'Activate' button to activate fonts" and the text frame font stays the same.

Steps to reproduce:
1. Create a new document in InDesign.
2. Create a new text frame with the word "Test." Save and then close.
3. In the same location as your new document, create a "Document fonts" folder. Copy an OTF or TTF font file into this folder. In my case, I copied "Sacremento-Regular.ttf" into this folder.
4. Reopen the new InDesign document you saved in step 2.
5. Select the text in the text frame. Note the current font (most likely Minion Pro).
6. From the type list, select the document-installed font you copied into the "Document fonts" folder.
7. Note the "Click 'Activate' button to activate fonts" error message, and that the font for the text frame has remained the same.

13 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Sam Cantrell shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    FIXED  ·  AdminAbhinav Kaushik (Quality Engineer, Adobe InDesign) responded  · 

    Hello All,

    Thank you for your patience all this while.
    This issue is now fixed in the latest update (Id 14.0.1) of InDesign CC.
    If you are unable to see the update notification yet, open the menu (three dots) from the top-right of Creative Cloud desktop application and click on ‘Check For App Updates’.

    Once the update button is shown against InDesign CC, click on the button to update your InDesign to Id 14.0.1 for the fix of the issue.
    Do let us know in the comments, if you face any problem with the new update.

    List of fixed issues can be found at: helpx.adobe.com/indesign/kb/fixed-issues.html

    Regards,
    InDesign Team

    5 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Jon Christopher Fitzgerald commented  ·   ·  Flag as inappropriate

        ridiculous - it's a permissions issue, it's always going to be a permissions issue. adobe is attempting to monopolize fonts. we already bought these fonts years ago, you can't deny what we already own.

      • Rebecca J commented  ·   ·  Flag as inappropriate

        I'm having issues since I updated to Windows 10. A font purchased is not working in InDesign anymore and yet the font works elsewhere on all other non-Adobe products.

      • Anonymous commented  ·   ·  Flag as inappropriate

        I am having the same issue. I'm trying to change a font to one that I have manually activated in Font Explorer Pro, but InDesign is still telling me to click the "activate" button, which I can not find.

      • Sam Cantrell commented  ·   ·  Flag as inappropriate

        Hi Ravi,

        Regarding the pre-release build, is there any way to install without admin privileges? Our IT department doesn't give us admin privileges on these machines.

        Also, would it install side-by-side with our current copy of InDesign 14.0, so we can run the stable version if the pre-release version crashes?

        Thank you.

      Feedback and Knowledge Base