Bug details

InDesign False Ligatures Bug

InDesign sometimes, seemingly randomly, replaces pairs such as hn, il, io, sy, ek, etc. with completely wrong glyph, such as accented Y, U, etc., when regular Ligature setting is applied. This has been a problem since CS5 and we recently had it occur in CC2015, so it is still there. Affected fonts have been many over the years, including licensed Adobe fonts. Fonts can be Open Type or PostScript. Language setting can be English US, UK, or seemingly anything else. The only thing that works to avoid it is to turn off Ligatures which is generally unacceptable, so the only workaround is a targeted GREP style to apply ligatures to only the pairs that should have them for that file. This is a long-standing problem which has been reported in forums various times and needs to be addressed. There is no sure fire way to reproduce the bug. Only thing that sometimes works is to brute force load/unload fonts until the problem occurs. It seems that once the problem occurs the first time it may then become more frequent on that computer. I know someone who has even seen the effects of this problem in printed material (i.e., in a book they were reading).

20 votes
Sign in
Sign in with: Facebook Google
Signed in as (Sign out)

We’ll send you updates on this idea

Scott Keeney shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →


Sign in
Sign in with: Facebook Google
Signed in as (Sign out)
  • sandra commented  ·   ·  Flag as inappropriate

    We are having issues with a ligature changing to an incorrect character. The only thing that works to avoid it is to turn off Ligature.

  • Anonymous commented  ·   ·  Flag as inappropriate

    We have this problem repeat when:

    Using the Palatino as Postscript
    Exporting the InDesign CC2018 and CC2019 file to an interactive PDF

    This does not appear in the InDesign file or the exported print pdf, or the packaged pdf.

    In this case, the ligature feature changed all "io" instances to superscripted 2, and "il" instances to ç.

    Our interactive pdf must be ADA compliant and read with assistive technology. We cannot use a print pdf.

    Thanks for any help with the issue.

  • Scott Keeney commented  ·   ·  Flag as inappropriate

    Appreciate the offer, Aman. As it turns out, our production dept recently ran into this problem again ("hn" pairs got turned into capital U with acute mark, Ú). My company would require a non-disclosure agreement to be signed (in addition to us getting client permission) before we could share the files. I have sent you a back channel email. Thanks again.

  • Thomas King commented  ·   ·  Flag as inappropriate

    It seems that the issue is happening with letter combinations that InDesign equates to a alternate glyph in the font. For instance "io" in Devotions changed to an uppercase O with a tilde. Sometimes it replaces a letter combination with a ligature. If you look on the attached file you will see whats going on.

  • Anonymous commented  ·   ·  Flag as inappropriate

    This is happening to me often. I unchecked ligatures in the character and open the file and there are ligatures in the file. I turn off ligatures and its OK for a while. Then it happens again, I check ligatures in the character panel and it's checked again.

  • John commented  ·   ·  Flag as inappropriate

    Has this ever been resolved as we are having the same issues.

    Cleaning font caches can resolve this, but we're looking for a more robust solution (one of which indesign does without us having to worry about missing it).

    It doesn't happen all the time and is very hard to replicate (as the thread suggests). It happens in CC2017 and CC2018 (as well as others reading other forums). The file is not the issue as when the problem occurs, we open the file on another mac and it is fine.

    It happens with various fonts, Avenir, Camphor, Myriad Pro so far we've had issues with.

    We run a mac environment, not all of the macs show the problem (even though they use the same fonts and versions of indesign and OS), it's confined to only a few of them.

    Is there any resolution to this?

  • Scott Keeney commented  ·   ·  Flag as inappropriate

    Aman, the problem is that the bug cannot be reproduced by taking some specific steps. The bug has been reported in the Adobe Forums multiple times for the past 7 years. It may be "rare" but if you are a company producing 1000s of titles per year, that so-called rarity is not rare enough, and when dealing with titles that will get 5 and sometimes 6 digit print runs, even once would be too much/expensive.

    For more details, why don't you read this thread which has the most thorough explication of the issue: https://forums.adobe.com/thread/792075

  • Gary commented  ·   ·  Flag as inappropriate

    I have the same issue in CS6. This guy had it in CS5.5 way back in 2011: https://forums.adobe.com/thread/792075 It is ridiculous that Adobe have not dealt with it yet (they can forget about me 'upgrading' to CC).

    I got around it by clearing font caches every day (using Smasher and/or Font Nuke) and switching ligatures off where I could. I had the problem with Goudy OS and Frutiger opentype fonts. It is not a problem that I can reproduce short of wondering if a file has lots of styles and some have ligatures enabled and others disabled.

  • Steve Jenks commented  ·   ·  Flag as inappropriate

    I have come across this a few times. It has always been a single font in a job that it happens to and, for me at least, has always been solved by disabling ligatures. Not ideal but it works.

  • Adminamaarora (Software Engineer, Adobe InDesign) commented  ·   ·  Flag as inappropriate

    Yes that is the problem of "false ligatures" which has been there since quite a few versions of Indesign. I am also unable to reproduce this issue consistently but yes it does occur.
    Do let me know if you find some concrete steps so that it can be looked into.


  • Anonymous commented  ·   ·  Flag as inappropriate

    We are using InDesign CC. In our InDesign file, the word "weeks" is spelled correctly. The font is Helvetica Neue LT Std. When we exported the file to PDF, "weeks" became "wefis"
    We have since been unable to recreate this oddity. We've turned ligatures off and on. We've also tried turning discretionary ligatures and contextual alternates on and off and was unable to reproduce the error. We've recreated the steps on 3 different computers but was unable to reproduce this error. We need to know how this error occurs and how it can be fixed so we can avoid costly spoilages in the future.

Feedback and Knowledge Base