Bug details

Export Tagging: ‘i’ character in class name exports as blank space

I just did the 2018 update, so I think it's the most recent version: 13.0 x64

I have a document template that contains many character and paragraph styles with export CSS tags that contain the lowercase ‘i’ in them. This character is being exported as a blank space, which completely breaks the CSS, like this:
should be: <p class="bright"></p>
getting: <p class="br ght"></p>

This problem was easily replicated in a fresh new document, so it’s something with InDesign, rather than my template file.

This workflow involves complex style mapping through to CSS classes. Because so many of the classes contain the character 'i', this problem has brought the workflow to a dead halt.

2 votes
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Eric shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
Need more info  ·  Anasuiya Gupta responded  · 

Thanks for sharing the CSS and document. Apparently, I was not able to reproduce the issue, Can you please try to creating new document with few paragraph styles and try exporting the document to HTML and see if the issue is resolved.

8 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Sam Highley commented  ·   ·  Flag as inappropriate

    We're having this issue as well. InDesign 13.0.1 x64.

    However, it only happens on our Windows 10 computer. The issue is not present on Windows 7 (same InDesign build).

    It appears to drop random letters out of class names. I can open the same file following an InDesign restart, redo the HTML export, and the next time around it'll drop different random letters.

  • Richard commented  ·   ·  Flag as inappropriate

    I was having the same problem but with the letter "f" disappearing from classes. However, restarting InDesign fixed the problem.

    Whether the problem recurs again, perhaps with a different letter, remains to be seen.

  • Eric commented  ·   ·  Flag as inappropriate

    I created a quick test document and it worked. Very strange. I guess you can close this ticket. Thanks.

  • Eric commented  ·   ·  Flag as inappropriate

    <<FILE ADDED>>

    I just did the 2018 update, so I think it's the most recent version: 13.0 x64

    I have a document template that contains many character and paragraph styles with export CSS tags that contain the lowercase ‘i’ in them. This character is being exported as a blank space, which completely breaks the CSS, like this:
    should be: <p class="bright"></p>
    getting: <p class="br ght"></p>

    This problem was easily replicated in a fresh new document, so it’s something with InDesign, rather than my template file.

    This workflow involves complex style mapping through to CSS classes. Because so many of the classes contain the character 'i', this problem has brought the workflow to a dead halt.

  • Eric commented  ·   ·  Flag as inappropriate

    How do I do that?

    I don't see any place to upload or attach a file.

  • Eric commented  ·   ·  Flag as inappropriate

    How do I do that?

    I don't see any place to upload or attach a file.

Feedback and Knowledge Base