Bug details

Wrong menu gets expanded while clicking on an item on Menu bar in InDesign

When InDesign is opened on my second screen, I can't select anything on top menus.

InDesign CC 2017 on Windows 10

32 votes
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

Hello All,

Thank you for your support all this while. The issue is now fixed in the latest update of InDesign.
Please upgrade to the new InDesign 14.0 from your Creative Cloud Application.

If you are unable to see the update yet, click on the menu (three dots) on the top right corner of Creative cloud app and click on “Check for App Updates”.

Let us know your feedback in the comment section.

Thanks,
Abhinav Kaushik
InDesign Team

49 comments

Comments are closed
  • Neil Daane commented  ·   ·  Flag as inappropriate

    Hello,

    Working with the user, we were unable to use the "Pre-Release\Beta InDesign CC 2019" 'fix' to resolve the issue - this is because of the version conflict when opening files between different versions of IDCC.

    It is not feasible for the client's company to all upgrade to the beta version to resolve one user's issue - especially not when they communicate with people outside their company to view InDesign CC files, and we cannot expect out-of-company users to also use the beta build.

    IS it possible this will be patched in the 2018 version of Adobe InDesign Creative Cloud?

  • gdg commented  ·   ·  Flag as inappropriate

    happens to us too. has there been any updates or workarounds to this? has anyone tried to reach adobe support?

  • Ireneusz Jakóbik commented  ·   ·  Flag as inappropriate

    I kind of solved this problem on my PC. It's a question of finding right combination of UI Scaling option in InDesign (Edit/Preferences/UI Scaling...) and display settings in Windows. Bug occured when UI scaling was set to "Scale to Higher Supported Scale Factor" and "Scale and layout" in Windows display settings was set to 100%. Chosing "Scale to Lower Supported Scale Factor" fixed the problem but the InDesign UI items were so small that they were hardly legible, so I changed "Scale and layout" to 125% and it worked fine.

  • Neil Daane commented  ·   ·  Flag as inappropriate

    I have a user with this issue as well - the "mouse displacement" happens when the user's HP laptop is plugged into their docking station while InDesign is open, adding another monitor. It effects the Menu Bar, when the drop-downs are present. Before clicking to make the drop-downs appear. the menu bar behaves normally. The only temporary fix is a full restart of the user's machine, which is irritating to the user and impractical.

    inDesign CC, Ver. 13.1 x64
    Windows 10 Pro, 1803 (OS Build 17134.228)
    Both monitors are 1920x1080p
    Monitor 1 is laptop monitor, inbuilt, 125% scaling set
    Monitor 2 is a Viewsonic VA2746 series monitor

    When the issue was triggered, I moved InDesign's window from Monitor 1 to 2. Monitor 1 appeared to have a greater "displacement" effect than Monitor 2. Other than that, the issue is identical to the video clips in the OP.

    I will try the Beta version and test with the user soon, I'll add a note to follow-up if it doesn't work.

  • Ireneusz Jakóbik commented  ·   ·  Flag as inappropriate

    It's already September and the issue still persists. I've just installed InDesign on a new HP Pavilion and the annoying top menu bug occures on an external monitor, while it's OK on the laptop's display.

  • SBray commented  ·   ·  Flag as inappropriate

    Sorry, one last message - this issue only occurs if my OS Display settings are set to Scale at 150%. If the OS Display is set to 100% the problem goes away in InDesign no matter what the UI Scaling is set to in InDesign Preferences (I have tried all 3 options - off, scale to lower and scale to higher and none have any effect when the OS Display is set to 100%) . The trouble is on 4K monitors an OS Display setting of 100% makes the interface text too tiny to read. Hope that helps.

  • SBray commented  ·   ·  Flag as inappropriate

    Just to add a little more detail, turning off or changing the settings in Preferences for UI Scaling has no affect. The problem occurs when this is on or off. Thank you, hope you have a solution.

  • SBray commented  ·   ·  Flag as inappropriate

    5 Aug 2018 - I have the same issue, running latest InDesign build and Windows 10, 2 x 4k monitors.
    Click on a menu item and it shows the list from the different menu one or two places to the right of where I click and hold. Driving me crazy. I can't afford the risk of being on a beta in a production environment. Are there any updates or bug fix for this?

  • Anonymous commented  ·   ·  Flag as inappropriate

    YES! Anytime I try to scroll through my File menu, it closes and my Window menu opens instead.

  • Anonymous commented  ·   ·  Flag as inappropriate

    My cursor jumps on each pull down menu so I end up not being to select anything. Frustrating!

  • Uwe commented  ·   ·  Flag as inappropriate

    Same here. Very anoying. When moving mouse the just click menu Closes and another far on the left opens.

  • Anonymous commented  ·   ·  Flag as inappropriate

    We have the same issue with not being able to scroll as see all the pages in the menu. One time restoring the preferences worked but not anymore. Ruins any productivity - huge amount of time wasted.

  • Zac Landry commented  ·   ·  Flag as inappropriate

    Correction... use the regular System... not enhanced. The enhanced created another bug. Large documents would not display properly when using a scroll mouse. Objects would pile up on top of eachother. Kinda like when you beat solitaire on windows.

  • Zac Landry commented  ·   ·  Flag as inappropriate

    This seemed to work for me. Not sure if its a permanent solution but I right clicked on the Indesign.exe file (not the shortcut) and went to properties and under "compatibility" I ticked the box for "Override High DPI Scaling Performed by: System (enhanced). Just to note, my windows 10 is set to scale to 150%. Don't know if that makes a difference.

  • Kelly Phillips commented  ·   ·  Flag as inappropriate

    I've seen issues like this that have been linked to screen resolution when you have a laptop connected to an external screen.

  • Anonymous commented  ·   ·  Flag as inappropriate

    I'm having this same issue but only on one of the 2 monitors. It is only messing up on whichever monitor I set as the main display.

  • Anonymous commented  ·   ·  Flag as inappropriate

    When I click on "File" the dropdown open for a second and then opens the "Window" dropdown instead.

← Previous 1 3

Feedback and Knowledge Base