Bug details

InDesign is very slow

The latest version is virtually unusable. If I select an image or text box on a layout I get a spinning wheel for 10 - 15 seconds. If I try to move something - spinning wheel 10-15 seconds. Try to save a document - spinning wheel 10-15 seconds. Previous versions did not behave this way on this same computer. No other applications behave this way.

My Mac is a late 2012 model, 32Gb RAM, 2 SSD drives; one for the OS / Applications and one for the customer files. GeForce video card (came with the computer with 1Gb RAM.

I have attached a Quicktime video of this behavior. The long pauses between seeing the cursor move are the times when the application has a spinning wheel. Then is works for a minute or two and starts all over again.

Dozens of users in the forums are reporting this problem with this version.

53 votes
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Terry Kauffman shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
Need more info  ·  Sumit Garg responded  · 

Hi ,

There can be multiple reasons for slow downs. Watching you uploaded video gave us little hint for possible causes.
However , can you please send us your document for more analysis. This will help us in isolating the actual root cause.

You can send us your packaged document with assets to “sharewithID@adobe.com” email address.

51 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Scott commented  ·   ·  Flag as inappropriate

    Found another possible workaround. Mac OS 10.13.4, InDesign 14.02. Turn off all networking once you have InDesign up and running. Go into System Preferences - Network. Turn off Wi-Fi, if you have on. And turn off Ethernet, if you have on. And any other connections to the internet. You will lose the "cloud" features, but at least you will be able to work.

  • Andreas Dobos commented  ·   ·  Flag as inappropriate

    The actual InDesign version 14.02 is simply not usable. Extremely slow, every few seconds the beach ball spins. I found a workaround: as long as I'm working in the .idml file format everything is fine. As soon as I open an .indd-file it slows down extremely, regardless if it is in front or back.

    This cannot be. Why don't you see that. Do you even test the software?

  • Mitchell Meek commented  ·   ·  Flag as inappropriate

    Yep, this is getting old. Why can't you guys at Adobe figure this out. We are losing productivity and patience. Your product is not cheap and we expect it to perform!!!!

  • Anonymous commented  ·   ·  Flag as inappropriate

    This is NOT FIXED on Mac OS 10.14.2, InDesign 14.01
    It is very jerky with delays all over the place.
    This has happened after upgrading the Mac OS and InDesign.

  • P Devitt commented  ·   ·  Flag as inappropriate

    Hey guys, it is not just happening in one document. It is on ALL DOCUMENT for every single little change.
    I go to type something into a box… 8 second spinning wheel.
    Insert a picture… same
    What is up? I have a brand new Touch Bar MacBook Pro circa 2018 and it is a constant aggravation.
    Help!

  • Samson Mwaka commented  ·   ·  Flag as inappropriate

    Hey, the beach ball has run for a solid 2 hours. I have tried saving the file as an IDML and later re-opening it as an INDD but all in vain. This is so frustrating, however it intensifies when I made Adobe Cloud online updates. i am using INDD CC 2017. Any help will be appreciated...

  • Anonymous commented  ·   ·  Flag as inappropriate

    Same problem. Late 2012 Imac. InDesign is now struggling with a basic brochure document when before the InDesign and 10.14 updates, it was fine.

  • Peter commented  ·   ·  Flag as inappropriate

    I had a pretty extenisvie catalogue created in Indesign with EasyCatalog which was increcible slow, especially when placing or copy/pasting images.

    This solved the issue for me:
    1. Export the document as an IDML file. (File -> export...)
    2. Open the IDML file and Save as a new INDD-file.
    3. Now the document works smooth again.

  • [Deleted User] commented  ·   ·  Flag as inappropriate

    **** was also giving me lots of problems with the spinning wheel/working slowly etc and I found this:

    Why is InDesign behaving erratically (crashing, running slowly)?
    If your InDesign preferences become corrupted, you can see some strange behavior. Luckily, it's easy to replace your InDesign preferences. Hold down Ctrl + Alt + Shift (Windows) or Cmd + Ctrl + Opt + Shift (Mac OS) while restarting InDesign.

    I have done this and it seems to have worked.

  • Patric commented  ·   ·  Flag as inappropriate

    I'm running it on an iMac Pro, 64 Gb RAM, top graphic card, and it's still very, very, slow. I gave up and went back to CS6; it has its issues running on modern OS, but at the end, it's still a lot faster.

    Sometimes I wonder what the software is tested on, Nasa's supercomputers?

  • Anonymous commented  ·   ·  Flag as inappropriate

    I'm having slowness when I place a file in Indesign C6. The files are not large. I wait a few minutes for it to place, sometimes up to 5 minutes. It SUCKKKKKS.

  • Anonymous commented  ·   ·  Flag as inappropriate

    I have iMac with 32 GB RAM, i7 processor. Recently updated to Adobe CC and after that the working with InDesign became really annoying. When designing magazine layout (I have worked before with InDesign CS6 without problems) the program now occasionally starts to freeze, making further working impossible. Closing and reopening the program doesn't help, only thing so far is the full restart for the computer. After that InDesign may work some time normally, sometimes even couple of hours but then it starts to freeze again.

  • Sophs commented  ·   ·  Flag as inappropriate

    I had the same problem. Spinning beachball for 15 seconds everytime I zoomed in, moved something or whatever.

    I suspected it was a font issue but I couldn't see what was happening with it.

    In desperation I copied the contents of an A3 layout, made a brand new document and pasted it back. Hey presto all the fonts have the pink box surrounding. I used Type, Find font to replace them and all is back to normal.

    Hope it works for you too.

  • Sophs commented  ·   ·  Flag as inappropriate

    I had the same problem. Spinning beachball for 15 seconds everytime I zoomed in, moved something or whatever.

    I suspected it was a font issue but I couldn't see what was happening with it.

    In desparation I copied the contents of an A3 layout, made a brand new document and pasted it back. Hey presto all the fonts have the pink box surrounding. I used Type, Find font to replace them and all is back to normal.

    Hope it works for you too.

  • Erwin commented  ·   ·  Flag as inappropriate

    Had the same problem in 13.1. Back to 13.0 solved the problem.
    I am not using Suitcase by the way.

  • Lynn commented  ·   ·  Flag as inappropriate

    Hi, I too had the same issue with the little beach ball holding everything up when working in InDesign.

    I tried a few things, but the one thing I think has definitely worked is turning off the Adobe Cloud file syncing. I think it tries to keep up with Every change you make so creates a lag. Anyway worth a try.

    Go to adobe cloud symbol in menu bar. Click on the three dots to the right and click Pause File Syncing. I do think I needed to restart Indesign for it to come into effect for some reason. All the best.

  • Steve commented  ·   ·  Flag as inappropriate

    We're having issues as well.. When I select a box containing a graphic, I get the spinning wheel for several seconds, same with when I place a new cursor in a text box, or move between pages. It's not tolerable. We work on Late 2012, 3.2 GHz Intel Core i5, 32 MB memory.

  • Anonymous commented  ·   ·  Flag as inappropriate

    I have been experiencing this very frustrating problem for some time and I'm pleased to discover this thread so I now know it's not just me. Every click or movement is the spinning wheel for 10-20 seconds. I have a brand new iMac and it's simply impossible to work like this.

← Previous 1 3

Feedback and Knowledge Base