Bug details

Spell check not working

I have installed the latest version of ID, and the spell check is not working. It does not detect misspelled words.

26 votes
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Mary Susan Weldon shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

36 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • richard kobs commented  ·   ·  Flag as inappropriate

    I'm having the same problem. Spell check is using a Dutch Dictionary.
    At the bottom of the spell check box it shows "Language: Dutch: 2005 Reform"
    I've selected the dictionary box on the right of the spell check box, and then "Language" changed the selection to "USA English" and clicked "Done".
    I've also checked "User Dictionary and its set to USA English
    How do I fix this

  • Ross commented  ·   ·  Flag as inappropriate

    i seem to be having many issues with text inc spelling, my text now doesn't highlight either

  • Tom Liszka commented  ·   ·  Flag as inappropriate

    I've encountered the same thing... My dictionary defaults to Spanish even though I have selected English in both the Character box and in Preferences>Dictionary>Language>English: USA.

    It's been driving me bonkers, but I found a temporary solution. Select the "Selection" tool and make sure nothing is highlighted/selected in your document. Then hit "COMMAND + A" (Mac User), THEN go to Type>Character and change the Language to English: USA or your desired language.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Actually I discovered the solution for me. I found that the issue was that: after the new version installation, all the check boxes under spelling in the preferences were unchecked – I’ve never had to actually tell InDesign that when I want spell check to work it needs to look for misspelled words. Look at Preferences > Spelling > Find: to see if the check boxes you want the spell check to find/highlight are checked.

  • Marm commented  ·   ·  Flag as inappropriate

    It's definitely a bug with the latest CC version. Was working fine until I updated my app earlier this week. Character styles are set, even switched the language just to test it. Mine is not working at all, as if the spell check never even scans the document.

  • Felix commented  ·   ·  Flag as inappropriate

    Spell check not working (does nothing after clicking on 'start'). Only occurs on some docs.

  • Pam Lynch commented  ·   ·  Flag as inappropriate

    Where is the fix people? We all agree, spell check is not working. Pretty frustrating for the non spelling creatives that we are!

  • KellyB commented  ·   ·  Flag as inappropriate

    Here might be something to try! I had the problem where spellcheck was highlighting EVERY word in a text box. I noticed in spellcheck the language was set to Italian. To fix the issue, I couldn't just switch the dictionary in spellcheck to English, I had to highlight all of the text and in the Character panel select English USA as the language at the bottom.

  • Mary commented  ·   ·  Flag as inappropriate

    My spell check has somehow defaulted to Hebrew even though I have repeatedly selected English in my preferences and dictionary. It highlights EVERY SINGLE WORD when I'm doing a spell check because my document is in English. For the love of god, this needs to be fixed ASAP. I'm using ID CC version 14.0.1

  • K Martin commented  ·   ·  Flag as inappropriate

    My spellcheck is not working either. What is going on? OS 10.13.6 , InDesign CC 14.0. I spend a lot of money on this product. Not happy.

  • M Hoerig commented  ·   ·  Flag as inappropriate

    Spell check dictionary "stuck" on Spanish even though I have selected English in both the Character box and in Preferences>Dictionary>Language>English: USA. Yet when I run spell check it wants to change all words to Spanish spelling...WTH?

  • Anonymous commented  ·   ·  Flag as inappropriate

    I just sent a portfolio PDF to a potential client with an blatant misspelling. How embarrassing! What to do?
    When I use spell check...nothing happens...just like it does when nothing is misspelled.

  • Anonymous commented  ·   ·  Flag as inappropriate

    my spell check isn't working either. Neither 2018 and 2019 versions are working. Did a spell check on the word "word" ... said "word" was an unknown word. No suggestions. This has been a none problem for too long. Where is Adobe on this? I have a "word" for them!

  • Ron Lewis commented  ·   ·  Flag as inappropriate

    Spell check did not catch "fr" as a spelling error. I exported my user dictionary and searched for "fr". So, it is not in MY dictionary.

    HOWEVER, Adobe ALREADY ALLOWS *FORCE* REMOVING words from dictionaries. In the menu system, I went to Edit >> Spelling >> User Dictionary ...

    In the dialog, I checked that "Target" specified the user dictionary I want to use. I made sure "Language" specified the language I want to use.

    AND THEN I changed "Dictionary List" to specify "Removed Words".

    I TYPED "fr" in the Word box and clicked Add.

    I saw that now the spelling error "fr" has the red squiggly line under it. And Ctrl+I spell check now flags this error.

    I WOULD GUESS THE REASON WHY THIS "BUG" IS TAKING SO LONG TO FIX is that the InDesign Spellcheck software is working correctly. The Software Developers do not have anything to change. Probably it's the Hunspell Dictionaries that have the mistake. And the Adobe software developers don't make changes to it.

    FORTUNATELY, the InDesign software developers made it so we don't have to wait for Hunspell to be corrected. We can *force* remove the misspellings in Hunspell using the method described.

← Previous 1

Feedback and Knowledge Base