Bug details

story editor

In my notes, the first character is always substituted with a missing font symbol. It looks fine in the main layout window, but this odd behavior occurs both in the Notes panel, as well as the same note when displayed in the story editor.

4 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Kelly Vaughn shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    FIXED  ·  Adminamaarora (Admin, Adobe InDesign) responded  · 

    Hi,
    We have fixed this issue with 13.1 March release of InDesign. Please update to the latest version and try out the fix.

    -Aman

    6 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Tim Murray commented  ·   ·  Flag as inappropriate

        On Thursday June 7 I posted this:

        Using InDesign 13.1, macOS 10.13.4. My files began life as new document in 13.1, but I had been using InDesign for some years.

        The trashing of prefs and cache-- on starting InDesign or manually in Finder -- did the trick for new files, but the missing glyph problem remained in old. But I found I could start a new document, then copy the entire old content and paste in the new, and for now I don't have the problem.

        And not that it matters, but when I tried to make a new note, the little Notes dialog came up for a split second with a missing-glyph X as the first character, then the typing area turned white and I could not type into it at all. I could create a new note only loading the clipboard and pasting into a new note the instant after it popped up.

        ===================

        I worked for many hours on 17 documents and all were fine all day Thursday -- but today, Friday the 8th, the problem is back in full force, only with a new twist.

        I got into a document and went to add a new note, and as earlier, I could not even type into the dialog. I saved the document to send to Adobe and to make for a small file, removed all of it, typed the word "text", and when I went to add a new note, it worked. I still had the missing glyph character at the left side, but I could type okay. So in summary, Notes fail in the full-size document, but work when the file is stripped down.

      • Kelly Vaughn commented  ·   ·  Flag as inappropriate

        I remember talking about this with an Adobe engineer a few years back. I think they told me to export the file as IDML and then open that and it should go away.My files are are old, inherited files that I keep repurposing for new projects. And I have thousands of them. I, too, have the problem where I can type only momentarily in the Notes field before it jumps away.

        I face this problem every day. I've resorted to typing my note as live text, then converting it to a note. Likewise, when I need to edit the note, I convert it from a note to Live text, then back again when I need it to be a note. This is n't an ideal situation, because occasionally, not all the text gets selected when I go to turn it back into a note. Then a year or so later when I look at the file again, I'll see, "Note to Kelly...."

        I don't recall this issue happening on files that are made fresh, rather than old files. With brand new files, bit the weird first character, as well as the jump-away behavior are gone.

      • Jeremy Bowman commented  ·   ·  Flag as inappropriate

        I'm getting this with InDesign 13.1 on a Mac (OS 10.13.4). It happens with a completely fresh documents, right after trashing preferences, as soon as I insert a table.

      • Payal Awasthi commented  ·   ·  Flag as inappropriate

        Hi,

        I tried the mentioned steps and it's working fine in ID CC 2108.

        For further investigation, kindly provide some bits of information :
        1) When you encounter this issue, quit InDesign and copy the Preferences and Cache to a shared location (like Dropbox, WeTransfer, etc.) and share the link.
        2) Is this happening even after clearing caches and preferences? (refer - forums.adobe.com/thread/52699)
        3) Is the issue specific to the document? Or does it occur with all documents?
        If specific to some document then share the document.
        4)Please mention your machine configuration like OS, Locale.

        You can also send files/links directly to paawasth@adobe.com

        - Payal (InDesign Team)

      • Kelly Vaughn commented  ·   ·  Flag as inappropriate

        This seems to be related to the font choice. The default font: Letter Gothic Std, always displays this way. I changed the font to another one and the first letter Xs went away. I then changed the font back to Letter Gothic Std and the Xs remained gone. But the behavior stayed in the Notes panel. It seems that the Notes Panel has now way of being connected to the font choice specified for the story editor. They should be connected.

      Feedback and Knowledge Base