Bug details

Data Merge: Remove blank lines for empty fields no longer works in CC2018

InDesign CC2018 English latest update. Since the update when data merging from a CSV file blank lines are not deleted. Yes, Remove Blank Lines is checked in the options.

3 votes
Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)

We’ll send you updates on this idea

Kathy Reece shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

Please refer to this article : https://indesignsecrets.com/rid-empty-lines-data-merge.php for more information on how the feature ‘Remove Blank Lines for Empty Fields’ work. Basically, if there are some fields that don’t have data in the CSV file, InDesign will remove the blank line in the merged document that is created. However, if you have an entire record(row) missing in the CSV file, it won’t remove that record in the merged document – you will still see an empty record in the merged document.

6 comments

Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
Submitting...
  • Chelsea commented  ·   ·  Flag as inappropriate

    I figured it out, I think! For me, I had to change the shift enter "soft returns" returns at the end of each line to a regular hard carriage return - then it worked!

  • Melanie commented  ·   ·  Flag as inappropriate

    Remove blank lines is not working for me either, and it's so frustrating. I hope Adobe fixes this soon. I've tried hard returns and soft returns and every merge hack I can think of but ... alas. No luck.

  • Leo Duffy commented  ·   ·  Flag as inappropriate

    I've only begun using InDesign's Data merge function but have considerable experience in databases. The 'Remove Blank Lines for Empty Fields does not seem to work in CC2018. In most cases it is putting a blank space in the field, even though there is no space in the data file.

    Our work around is a series of find and replace runs on the merged file.

    Find Return Space Return (^p ^p) and Replace with Return (^p) - gets rid of double returns with a leading space on the 2nd line.

    Find return space (^p ) and replace with return (^p) - gets rid of a leading space on the 2nd line.

    Find return return (^p^p) and replace with return (^p) - gets rid of double returns.

  • Todd commented  ·   ·  Flag as inappropriate

    My 2 cents, check to make sure the line that is linked in the artwork has a hard return before it. Soft returns (shift+enter) don't trigger the remove line feature. That trips me up all the time.

  • Kathy Reece commented  ·   ·  Flag as inappropriate

    As you can see in my post, I have the Remove Blank Lines checked. It is not a blank row in the CSV file, it's a blank column

  • Cordula Hofacker commented  ·   ·  Flag as inappropriate

    Obviously, the "remove blank lines for empty fields" is not working in the current german version of InDesign CC 12.1.0.56.

Feedback and Knowledge Base