Bug details

Add the Ability to turn off hover scrolling

Hover Scrolling lets you interact with the dropdown menus without ever having to click on them. Sounds cool, right?

Normally, this is not a problem, because you can easily see what has been changed because you've got an object selected. But when working with conditional text, the conditional text indicator visibility is a GLOBAL setting, and thus, hover scrolling over it can change your document, even with nothing selected. And if you're not on a page with conditional text. you'd never even know that your document got changed, until you send it to print!

This has been plaguing me for over four years and there is no way to turn it off.

I write a blog article about this and have been documenting it for four years: https://indesignsecrets.com/hover-scrolling-indesign-cc-feature-bug.php

I have made a video about it here: https://youtu.be/5uBI77mothA

InDesign needs to add a preference to our off this setting. It would be so easy! There are already preferences to disable the other annoying features, like Publish Online the new start workspace, and the new document dialog box. You could put it under "Preferences > General."

Adobe, please fix this!

20 votes
Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)

We’ll send you updates on this idea

Kelly Vaughn shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

15 comments

Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
Submitting...
  • Kelly Vaughn commented  ·   ·  Flag as inappropriate

    Nearly SIX years after this was introduced, it it still causing me to have to reprint pages and reexport PDFs. Why do we not have an option to turn this off? How hard it is to add a checkbox in Preferences?

  • bn commented  ·   ·  Flag as inappropriate

    i absolutely hate this, it causes so many misses. Changing kerning values needs to be done twice, it won't take the first time, it changes to a random value and you have to do it again, hit return this time.

    Final copy for approval suddenly turned italics, etc. omg. pls. some take it off. There was MagicPrefs before which turn off this behavior, but now MagicPrefs is not being supported in newer mac os.

  • Rob Gale commented  ·   ·  Flag as inappropriate

    Here's another +1 for the ability to turn off this feature. It's really too easy to ***** up my documents as others have said.

  • Ashley G commented  ·   ·  Flag as inappropriate

    Please fix this!!!! I have to be very careful to only 2-finger scroll over the scrollbar so as to not touch any of the values and mess up my work. It really slows me down.

  • Drawcard commented  ·   ·  Flag as inappropriate

    InDesign 2019 introduces the all encompassing Properties panel, which is great except for the fact that if you need to scroll the panel up or down on a lower resolution monitor (or you're using InDesign in a smaller window), there's roughly a 75-80% chance your mouse will get trapped inside a scrollable field and your document will be ruined from all the unwanted scroll activity. This really, really, really needs to be addressed...

    PS. This would truly be playing havoc with accessibility users who use larger text on their monitors too.

  • Claus Hyldal commented  ·   ·  Flag as inappropriate

    Yaiks. The Hover Scrolling is a potential disaster generator.
    Please make it an OPT-IN functionality. Thanks.

  • Kelly commented  ·   ·  Flag as inappropriate

    I agree with Bestsy, please add an option to turn this monster off! I don't have time to check my files for changes I did not make and that hover scroll made without me noticing. Enraging. Stop messing around with features just because you can.

  • Anonymous commented  ·   ·  Flag as inappropriate

    II love Indesign, but is there any way Adobe could give us another preference that i sorely need?
    You have made the tools so fine-lined and small that no matter what interface color choice i use, they are very hard to see. Can you either make the toolbox able to be enlarged, or make the lines of the tools a little thicker? Some of us are no longer 20 years old, but are still working and have a hard time with eye problems.
    another gripe about the toolbox is that a few editions back, the pen, pencil, brush and eraser were clearly different. Now, along with being so fine-lined, they are similar-looking. Please help us who are still out here working, not just looking at how "elegant" the apps are.

  • Betsy commented  ·   ·  Flag as inappropriate

    Please add an option to turn this monster off! It took me a long time to understand why my text was mysteriously changing.

  • Christy Kelleher commented  ·   ·  Flag as inappropriate

    Please fix Hover Scrolling or give us a way to turn it off - it is not a helpful feature. In fact I hate this feature and use a Magic Mouse, which I'm sure makes it worse. The InDesign the window just starts randomly moving around and you have to wait until it stops. It is wasting my time and very frustrating.

  • Anonymous commented  ·   ·  Flag as inappropriate

    YES! Finally, I understand why my documents were changing. I thought I was just starting to lose my edge, I was getting sloppy. I can't tell you how long I've been finding/fixing/correcting because of this ridiculous "feature". This, in my opinion, is not a feature at all. I work with very large, 200+ page documents. I use paragraph styles, character styles, table styles, object styles, etc. in an effort to format my documents faster and more consistently. I have lost my MIND trying to figure out how random bits of text would suddenly appear in a different point size or weight. Please, Adobe, consider making this a preference that the user can opt to turn off.

Feedback and Knowledge Base