Adobe InDesign: Bugs

When filing a new bug, please provide:

  1. Version of Adobe InDesign, InCopy or InDesign Server
  2. Steps to reproduce the issues
  3. Expected result
  4. Actual result
  5. Test file, screenshot, video or GIF capturing the issue (optional)

Join the InDesign Prerelease Program to try out the new features and the bug fixes that are available in beta builds.

Bug details

(thinking…)

Enter your idea and we'll search to see if someone has already suggested it.

If a similar idea already exists, you can support and comment on it.

If it doesn't exist, you can post your idea so others can support it.

Enter your idea and we'll search to see if someone has already suggested it.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. links labeled as "modified" when actually "OK"

    ID= v13.1
    MacOS= 10.13.4

    Problem: Open any ID file and links that should be "OK" are labeled as "modified". I do not get any error window that pops up notifying me this. Without taking any action, I close the ID file and reopen it and links are now labeled as "OK". Open it up a third time and links are "OK". I QUIT out of ID and open that same file and see links as "OK" and now they are labeled as "modified". This process repeats. Attached video to show. All links in these ID files are not modified or…

    10 votes
    Sign in
    (thinking…)
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    15 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →

    Hi,
    Based on our analysis we found that there are two set of users facing the issue:

    Set 1: Users with Universal Type Client v6.1.6 installed.
    The issue is resolved for them with Universal Type Client v6.1.7

    Set 2: Users not with Universal Type Client v6.1.6 installed.
    For these user’s looking from the attached video, we can see that no pop up for modified links was shown on opening the file.
    In this case , no sync call is done on opening the document for fetching the links status. Till the time the call results are fetched, links panel shows the link status same as the one registered at last instance of this document close. So, for these users, showing modified links is ‘AsDesigned’.
    But we would like to know the below two things to clearly verify that is ‘AsDesigned’:
    1: Does the link status get corrected after keeping the…

  2. Color Reading Completely Incorrectly

    Adobe. This is an insane problem to have not fixed.

    Colors are seriously displaying incorrectly. From one program to another the colors look different and they do not at all match the way the color read in 2018.

    The attached shows the same color in Indesign 2019 (left) and Illustrator 2019 (right)

    This is a serious issue that people have been having since the 2019 update and I cannot believe there is not an update to fix this yet.

    Every time Adobe releases an update lately I hesitate to download. The ideas behind the updates are intended to increase functionality…

    2 votes
    Sign in
    (thinking…)
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  3. TIff

    Can't place TIF or PNG files into InDesign. The internet tells me that I can, however I've been trying for hours and it only works when I convert to JPG.

    1 vote
    Sign in
    (thinking…)
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  4. High Quality Display Not working

    I have used INDD for about 15 years. Very experienced. but just upgraded it to CC2019 along with Mac OS Mojave 10.14.1. I can no longer see images in high quality (since the upgrades). I have triple checked everything. (image res, all INDD settings etc..) Is this a known issue?

    1 vote
    Sign in
    (thinking…)
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  5. images are missing

    When opening v.2018 Indesign files or new v.2019 files, bitmap images are not displayed. Images are shown as gray boxes with an X across the box (see attached). Display settings changes do not remedy the problem.

    I have to work in v.2018 until this is fixed.

    ID version 14.0

    1 vote
    Sign in
    (thinking…)
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  6. InDesign Enlarges New Assets larger than their Bounding Box

    Since the new update, every time I drag an image or logo, etc. into Indesign and drag out how large I want the asset to be displayed....
    - Indesign places it (after a short delay), but makes the bounding box smaller than the actual asset. So the logo gets partially covered by the bounding box.

    I'm not using the content aware sizing or anything. The bounding box should exactly match the asset as its being dragged in for the first time. Very frustrating.

    1 vote
    Sign in
    (thinking…)
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →

    Hi Patrick,
    We’re sorry to hear that the latest version of InDesign is not behaving as per your expectations.
    You said that you are not using Content Aware Sizing. However, could you check once again to see if you have enabled the setting ‘Make Content-Aware Fit the default frame fitting option’ in the Preferences dialog (under General section)?
    Also it would be helpful if you can show us a quick demo of the issue and/or share the file (along with the asset).

    Ravi Kiran
    Adobe InDesign team

  7. cannot place this file. No filter found for requested operation

    May 16, 1028

    I am using macOS High Sierra, version 10.13.4 which I updated a few days ago.

    I was/am using the InDesign CC 2018 version 13.1.

    I got/am still getting the same error, after uninstalling and reinstalling InDesign.

    1. New document in inDesign CC 2018.
    2. Letter size w/bleeding edges.
    3. Selected the document.
    4. Did a CMD+D and selected my .psd file, which was created on April 26, 2018.

    Result: Error
    Cannot place this file. No filter found for requested information.

    Thank you in advance.

    1 vote
    Sign in
    (thinking…)
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  8. copy with drag and press alt makes two copies of the objekt. It used to copy once - now it produces two more objekts

    Indesign 13.1
    Mac 10.11.6 El Capitan
    copyfunction drag + press alt makes two copies of the objekt. It used to copy one - now it produces two objects

    1 vote
    Sign in
    (thinking…)
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  9. Placing illustrator files is very very very slow after update

    After updating AI and INDD, placing AI files into INDD is taking a very long time. I made an update to an AI file that was placed into an existing INDD files that contains 13 placed AI files. I only updated a few of the linked AI files. Prior to the AI and INDD update, updating these placed links took a few seconds each max. Now, just to update the two links takes about 2 minutes.

    This MAY be an AI bug, but I don't know how make that determination as I updated bothat the same time.

    1 vote
    Sign in
    (thinking…)
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Need more info  ·  0 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  10. For some reason my design in indesign is not fully visible when i am working on it, even when i select fast display or high quality display

    it is so annoying to be working on my design and not to be able to see all of my work on my screen as so much of it is blank, and is only visible when i export it as a jpeg. THis is so unprofessional and inconsistent when trying to design that i can clearly see all of my work as i edit and improve it. Can you please investigate and improve the software so my work is visible as i continue to edit. Also have the screen is in grey and the other half in white like a…

    1 vote
    Sign in
    (thinking…)
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  11. Find Missing Pathfinder

    Please restore now Missing Pathfinder in CC 2018
    I teach InDesign and the practicality of Pathfinders in InDesign.
    Now it’s gone missing, no explanation !!
    Disappointed and worried. What is your point ?

    1 vote
    Sign in
    (thinking…)
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
  12. Rendering of Bitmaps with High Sierra not as smooth as they should be.

    Since upgrading to High Sierra, I am finding in High Quality Display, bitmaps are not rendering smoothly on screen or in print.

    Exporting to PDFs gets over this, but not great when composing, and needing to see images as they will be.

    1 vote
    Sign in
    (thinking…)
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Graphics/Images/Assets  ·  Flag idea as inappropriate…  ·  Admin →
    Need more info  ·  Sumit Garg responded

    Hi,

    Can you please add a screenshot for this issue.
    Also, is GPU enabled on your machines?

  • Don't see your idea?

Feedback and Knowledge Base