Bug details

Stroke Drawing Order not working

InDesign 2019 on MacOS 10.13.6

Steps to reproduce
Define table stroke using the proxy in the Control panel (see screenshot) and try to change the Stroke Drawing Order.

Expected result
Stroke Drawing Order "Row Strokes In Front" should be as selected in "Table Options"

Actual result
Row Strokes are not in front. All strokes which are altered using the control panel options remain unchanged.
If a new table is setup using only the menu options (Cell Options > Strokes And Fills) everything works fine.

5 votes
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

In the Table Setup dialog, do the following:

In the Row Strokes section (2nd tab), choose Alternating Pattern : Every Other Row and then make the First 1 Rows and Next 1 Rows the exact same settings.

In the Column Strokes section (3rd tab), choose Alternating Pattern: Every Other Column and then make the First 1 Columns and Next 1 Columns the exact same settings.

In the Table Setup section (1st tab), you can set the Table Border as 0mm and Stroke Drawing Order as ‘Row Strokes in Front’.

Most probably this should help you get the results you are after. Try this out and let us know if it helps.

Adobe InDesign team

2 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • AdminRavi Kiran (Senior Lead Quality Engineer, Adobe InDesign) commented  ·   ·  Flag as inappropriate

    In the Proxy in the Control panel, the order in which you change the Column/Row matters. So if you want to make the Row strokes appear on top of the Column strokes, then first change the Column Strokes, followed by Row Strokes (even if those row strokes remain their default, just change them to something else and change them back). And it should work, I guess.
    FWIW, that is how it works for now and knowing that it works like that, you'll have to take that into account while working.

    Adobe InDesign team

  • Anonymous commented  ·   ·  Flag as inappropriate

    Hi Ravi, thanks for your reply. Unfortunately it is not very helpful. As I have written if you use the options in the Table Setup dialog everything works as it should.
    The problem is: when I use the table proxy in the Control Panel to e.g. change the stroke color in one row this affects the stroke drawing order and the previously made settings are overwritten and then cannot be changed again in the Table Setup dialog.
    My workaround to get all row strokes in front is to select all rows and then change e.g. the color back and forth.

Feedback and Knowledge Base