Bug details

InDesign 13.0.1 can not follow an alias on a server share anymore

InDesign 13.0.1 on a apple mac running 10.13.3 does not recognize alias (links) on a server share anymore. Photoshop still does.

Steps: Go to a server share, no matter if an smb or afp share.
Create a folder A. Place an file inside, e. g. 1.jpeg
.
Create an alias from folder A => A alias.
In InDesign choose OPEN:
Go to the server share
The Folder A is in black typo an available. Highlight A and you see the file.
The Alias A alias is gray, InDesign does not recognize the link.
Do the same in Photoshop, you will see the file no matter if you chose the folder or the alias.
All the years this worked in InDesign too (as expected).

5 votes
Sign in
(thinking…)
Password icon
Signed in as (Sign out)

We’ll send you updates on this idea

Thomas shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

If you create an alias of a folder (located on a server) and drag it to the desktop, it works. For quick creation of aliases this way, press Option-Command while you drag the original item to the desktop.
Note : Accessing items of an folder’s alias located on a server has not worked in previous releases of InDesign too.

5 comments

Sign in
(thinking…)
Password icon
Signed in as (Sign out)
Submitting...
  • Lara commented  ·   ·  Flag as inappropriate

    We are having the same problem with our workflow. Alias folders are no longer accessible within InDesign, Illustrator or Photoshop--even if the aliases are located on desktops instead of within servers. In order to place links or open files within these programs, our design team now has to manually navigate to the project folder on the server (4-5 clicks in) instead of being able to navigate by aliases in their working folder.

    I've used this workflow with aliases successfully at multiple employers from 2012-2017, and now it no longer works. It's a huge problem and step backwards, as it completely breaks a previously tried and true design workflow.

  • Florin commented  ·   ·  Flag as inappropriate

    @Ravi Kiran, this is just not true! In the past (from 2011 to 2017) it worked perfect the whole time

  • Florin commented  ·   ·  Flag as inappropriate

    we have the same problem on all systems since one year.
    Thought this is a apple problem. But now i know, its adobe. please solve this problem! we need to work with aliases on server

  • PS commented  ·   ·  Flag as inappropriate

    I have the same problem since updating to High Sierra (10.10.3) from Sierra (10.12.?) a few days ago. We have all our projects on a Synology NAS with Aliases created on the NAS pointing to other folders on the NAS. This has worked very well (with Indesign and otherwise) for years. Interestingly, in InDesign 5.5 the Aliases are also grayed out in a "Place file…" dialog but are clickable an working.. In InDesign CC 2017 it is not working, nor in the current CC 2018 (v. 13.1). So it proves that it is possible under High Sierra (Indesign 5.5 can do it) to correctly follow Aliases on a NAS pointing to other locations on a NAS. Please look into this again as we have years worth of Aliases on our NAS which we wouldn't want to have to recreate neither on the NAS, nor on each of our Desktops :-)
    Many thanks!
    PS

  • Thomas commented  ·   ·  Flag as inappropriate

    Hi, I know it works on the desktop, but it should be an shortcut on a specific folder on the server to another folder.
    The alias does not help on the desktop
    Note a) It works in Photoshop, why not in InDesign????
    (Also in quite every other App I tested)
    Note b) I am working with InDesign since Version 2. It worked nearly all the time. I am not sure when it stopped working, but it worked in previous versions, eg CC 2017.

Feedback and Knowledge Base