Bug details

Text rendered bold when using transparencies

When using transparent boxes or png images, InDesign will randomly render some text bold. This occurs both on screen and when printing. The only way to avoid it is by not using transparencies, which is annoying. People have been complaining about this since 2011! Get your sh*t together adobe. Come on.

4 votes
Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)

We’ll send you updates on this idea

Maria shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

4 comments

Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
Submitting...
  • Anonymous commented  ·   ·  Flag as inappropriate

    I'm experiencing the same problem again in the CC 2019 version. Only the pages with text+jpg are exported properly. The pages with any other image type with some transparency, i.e. psd, ai, even png, have bold text after exporting to pdf.

    It's an old issue, coming back every now and then in many InDesign editions in the past. So we all should know how to deal with it, shouldn't we? Well, here is the rub. The trick with the text placed on a separate layer on the top doesn't work anymore. Nothing works, actually. It's a major bug. A reason to downgrade to the last correct version. I needed to export a very important work today and I have spent most of my day trying to work this out. I have downgraded to CS6 eventually, just to be sure that it would work. And it did, but hey! This is not the solution.

    Another workaround that I know of is to print your publication to pdf instead of exporting. But still. It is a huge bug and we need you, ADOBE, to deal with it real fast.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Is there a fix already? It might be just a windows problem. Some time ago I asked a Mac user if he experienced the same, but he had no issues.

  • Anonymous commented  ·   ·  Flag as inappropriate

    1. Indesign version is CC 2018, OS: Windows 10
    2.
    * Make sure anti-aliasing is turned ON.
    * Type text with any font.
    * Apply transparency effect or paste transparent image
    * The text immedietly looks jagged and also thinner
    * After the transparency is removed everything looks normal.
    * To see the effect clearly, use white text on black background or zoom.
    3. Expected result: Render the text with anti-aliasing
    4. Actual result: Text is jagged, thinner, without anti-aliasing
    5. http://postimg.cz/i/NprdR
    * The first one is when transparency is presented, the second one is the CORRECT.

  • Anonymous commented  ·   ·  Flag as inappropriate

    I have kinda similar problem, when transparency is presented, all text starts to lack antialiasing. It disappears after I chnage the Transparency blend mode to RGB, but I have to remeber to change it back to CMYK when done.

Feedback and Knowledge Base