Adobe InDesign: Bugs

When filing a new bug, please provide:

  1. Version of Adobe InDesign, InCopy or InDesign Server
  2. Steps to reproduce the issues
  3. Expected result
  4. Actual result
  5. Test file, screenshot, video or GIF capturing the issue (optional)
If you are facing a crash in InDesign, please submit the crash report as well. How to Submit Crash Report
Join the InDesign Prerelease Program to try out the new features and the bug fixes that are available in beta builds.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. XML structures and footnotes/endnotes

    This is a point which was subject of lot of discussion since years in several forums. Even this uservoice mentions it (partly) sometime but obviously it hasn't been considered at all.
    In InDesign, a footnote can't contain xml structures.
    In InDesign, it is not possible to map an xml element to the footnote object.
    This is really weird, since:
    a) mapping XML element to an InDesign object is something exiting already for tables thanks to attribute aid:table. So why not having set an attribute aid:note, with values "footnote" and "endnote" and implementing this?
    b) footnotes and endnotes can contain by…

    32 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Others  ·  Flag idea as inappropriate…  ·  Admin →
  2. [BUG] Text from pdf disappears when placing a pdf

    When placing a (PitStop server certified) PDF some texts in the placed PDF disappear (on screen as well as print).
    Only happens in latests Indesign/photoshop/illustrator, older versions work fine.

    PDF has no errors or problems in Acrobat pro preflight and PitStop server.

    Confirmed by several users in community forum:
    https://community.adobe.com/t5/indesign/placed-pdf-file-into-indesing-part-of-pdf-file-disappear/m-p/11258536?page=3

    Sample file attached.

    3 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Others  ·  Flag idea as inappropriate…  ·  Admin →
  3. The app.doScript () statement no longer works since version 15.1.1...

    The script that I am attaching works up to version 15.0 and does not work with the next versions (certainly with version 15.1.1). The error that returns is "Unable to load Adobe Indesign Type Library 1.0" (translated from Italian). It does not seem to me that there are incompatibilities with the app.doScript () statement that generates the error.

    3 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Others  ·  Flag idea as inappropriate…  ·  Admin →
  4. color profile changed after copying image box

    color profile changed after copying image box

    InDesign 15.1.1 x64
    Windows 10 Pro

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Others  ·  Flag idea as inappropriate…  ·  Admin →
  5. CC library icons (svg files) not copying over correctly

    Version: inDesign 2020

    When I drag, copy over, or place a linked icon (svg/eps) file from our corporate CC library, it only displays a white box.

    I have asked a couple of coworkers to try the same thing and they don't have any issues.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Others  ·  Flag idea as inappropriate…  ·  Admin →
  6. Major System Font Issue!

    WHAT THE FONT!?!

    Our publishing company recently ran the InDesign update (to 15.0.2) and have discovered some major font issues. I have narrowed it down to InDesign 15.0.2, macOS Catalina 10.15.3, and Suitcase Fusion 21.0.0. I actually don't think Suitcase has too much to do with this, because the problem occurred after the InDesign update, but it's our font management software so I'm including it. Basically it appears system fonts have become problematic with InDesign. Packaged files are suddenly showing up with lots of the dreaded pink. I have tested about everything I can. I even created some very simple…

    104 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    135 comments  ·  Others  ·  Flag idea as inappropriate…  ·  Admin →
  7. Variable fonts broken with World Ready Paragraph Composer

    Using the World-ready composer essentially breaks the glyph width interpolation of Variable Fonts. The outcome is that text set in a Variable Font will receive the Variable Font's default style's horizontal glyph widths for any axis location, resulting in unusable overlap or gaps.

    Attached you find a sample Indesign file with comparison and a screenshot thereof. This happens with any Variable Font I have tested so var, but to complete the same test case as included, download https://github.com/adobe-fonts/source-sans-pro/releases/download/3.006R/source-sans-pro-3.006R.zip and install VAR/SourceSansVariable-Roman.otf as well as OTF/*.otf files.

    Link to Indesign file: https://www.dropbox.com/s/h8fpld7ks7k8rb4/bug-report-variable-font-world-ready-composer.indd?dl=0

    2 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Others  ·  Flag idea as inappropriate…  ·  Admin →
  8. Mouse very slow during mail merge

    When exporting to a PDF using Indesign Mail Merge, the mouse is very slow, even if in other programs. That makes the computer unusable during export of large PDF's.

    I found that only when the Windows Task Manager is on the front, the mouse acts normal again, but when I the Task Manager loses focus, the mouse is slow again.

    We have this problem on our Windows PC's. On my Mac it works fine.

    We use the latest Indesign (15.0.1)

    9 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Others  ·  Flag idea as inappropriate…  ·  Admin →
  9. Live Preflight reporting a false error with OpenType Type 1 fonts

    InDesign's Live Preflight will wrongly flag an OpenType Type 1 (PostScript flavored) font as invalid when the font appears in a linked graphic.

    To recreate:
    1. Create an InDesign Preflight Profile
    2. Set it to flag Type 1 fonts as Font Type Not allowed.
    3. Create a new InDesign document.
    4. Add text using an OpenType Type 1 font.
    5. Turn on the preflight.
    The preflight will not signal an error. This is expected and correct.
    6. Now export a PDF of the document created.
    7. Create a new InDesign document.
    8. Place the PDF as a linked graphic into…

    15 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Others  ·  Flag idea as inappropriate…  ·  Admin →
  10. Data Merge function "Remove Blank Lines for Empty Fields" deletes the wrong paragraph

    Version of Adobe InDesign, InCopy or InDesign Server

    Adobe InDesign 15.0.1

    macOS High Sierra 10.13.6

    iMac 27 Zoll End 2012

    Steps to reproduce the issues

    See also attached video

    Open Document "02VKLeerzeilenTEMPEnde.indd"
    Open Data-Merge Panel
    Generate a merged document with click on the button
    Uncheck "Remove Blank Lines for Empty Fields" in Content Placement Options
    Press [OK]
    Repeat Step 3 this time Check "Remove Blank Lines for Empty Fields" in Content Placement Options
    Press [OK]
    Put the documents side by side
    Activate "Show Style override" in the paragraph panel
    Jump to page 2
    On the left…

    19 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    12 comments  ·  Others  ·  Flag idea as inappropriate…  ·  Admin →
  11. Tillägg borta i InDesign 2020

    Version: Indesign 2020

    Under Fönster finns inte längre "tillägg" vilket gör att MediaFlowPro inte går att få in.

    4 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Others  ·  Flag idea as inappropriate…  ·  Admin →
  12. Drag-Duplicating using Alt/Opt key does not work if key is pressed after dragging

    InDesign 2020 OPTION Duplicate is now broken, just like Photoshop has always been.

    Don't make me commit to the duplicate before moving an item.

    Sometimes I'll move a box, then realize I intended to duplicate it, so then I'll press OPTION... now I have to commit to it FIRST.

    Fix this and stop breaking things!

    20 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    19 comments  ·  Others  ·  Flag idea as inappropriate…  ·  Admin →

    While we’re still working to make the fix available for this issue, we suggest a workaround to overcome it.

    Open Preferences > Interface. At the bottom of this dialog, change “Live Screen Drawing” to “Never”.

    As mentioned above, we’re working to fix this issue.
    Hope this helps.


    Adobe InDesign team

  13. CC2020: Alternate text for hyperlinks

    In CC2020 a new function for writing alternate text for links was introduced.
    Using this function and generating a PDF Leeds to wrong PDF notation. The alt text in PDF is presented by alt text, which is forbidden in the PDF world, where alt text only should be used for non text elements, e.g. pictures. By presenting only the alt text the accessibility is lost – this is against the goal to hav a better output!
    A correct output would lead to a content entry.

    Note: Alt text for links is under discussion, as such alt text is not present…

    18 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    7 comments  ·  Others  ·  Flag idea as inappropriate…  ·  Admin →
  14. Command-O or command-N doesn't work after Indesign starts up.

    This has been an annoying bug for a while. If you open indesign, then use the command-O or command-N key to open/create a file, nothing happens. You just get an alert sound.

    9 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Others  ·  Flag idea as inappropriate…  ·  Admin →
  15. Multiple listings of same font in Find Font menu

    There are multiple listings of the same font in the Find Font menu in CC2019. All information is the same, all applied characters are the same, but there is odd behavior.

    --FileACC2019WithDocumentsfontsfolder.png shows double listing of Trade Gothic LT Pro Roman.

    --FileACC2019WithoutDocumentfontsfolder.png (when I take away access to Document fonts folder, no other changes), one instance switches to "Regular" instead of "Roman"

    --FileACC2017WithDocumentfontsfolder.png shows what happens with I open this file in CC2017 (no double listing)

    --FileACC2017WithoutDocumentfontsfolder.png (Document fonts folder hidden) shows what happens with I open this file in CC2017 (no…

    13 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    9 comments  ·  Others  ·  Flag idea as inappropriate…  ·  Admin →
  16. 1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Others  ·  Flag idea as inappropriate…  ·  Admin →
  17. Hyperlinks copy/pasted between files *appear* to break after source document is removed.

    Using CC2019 on a Mac running High Sierra

    Steps to reproduce:
    1) Create a document with a few hyperlinks in it.
    2) Whilst this document is open, open a 2nd document, and copy/paste the links from one document to the other.
    3) Save both and close.
    4) Trash source document

    Expected result: hyper links should work in Target document as expected.

    Actual result: hyperlinks all appear broken in document. Whilst an exported PDF appears to still work, ID reports all those links as broken.

    Other details:
    If you retrieve the source document from the trash, it the links in the…

    14 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    12 comments  ·  Others  ·  Flag idea as inappropriate…  ·  Admin →
  18. InDesign, latest version. GREP: find period (.) character followed by endnote reference number. Should be (\.)(~U) but doesn't seem to work.

    GREP: find period (.) character followed by endnote reference number. Should be (.)(~U) but doesn't seem to work.

    8 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Others  ·  Flag idea as inappropriate…  ·  Admin →

    Thanks for reporting the issue. As confirmed from you all, the crash issue is not happening with latest InDesign build. The only remaining issue is that of Grep not working when a period is followed by an endnote marker

    We will look into the issue shortly.

    -InDesign

  19. InDesign .indd Files Opening in After Effects

    1 - InDesign CC version 14.0.2
    2 - Double click a .indd file in bridge
    3 - Opens in InDesign
    4 - Opens in After Effects

    I've reinstalled InDesign and reset the default program in windows. Any help with this would be appreciated.

    Thanks!

    0 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Others  ·  Flag idea as inappropriate…  ·  Admin →
  20. Anchored Object Lock/Prevent Manual Position Override

    The Prevent Manual Positioning creates a Locked Object, but unlocking the widget doesn't remove the Prevent manual override.

    When you check to "Prevent Manual Override" an anchored object receives a lock adornment. An object Style can be created from this object. If that lock is unlocked the Object style shows as override, but the "Prevent Manual Override" is still checked.

    If the object style is redefined. The lock adornment is still unlocked, and the "Prevent Manual Positioning" is still checked. Reapplying the style locks the object.

    There should be more consistent behaviour of "Prevent Manual Positioning" and the "Lock". Even…

    2 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Others  ·  Flag idea as inappropriate…  ·  Admin →
← Previous 1
  • Don't see your idea?

Feedback and Knowledge Base