Bug details

When flowing text in multiple textboxes, Object Styles settings are ignored

1. Indesign 13.0.1 OSX
2. Create an object style and set it as the default for new Text Frames. Create a new Text Frame. Click on the linking box at the corner and hold down alt to link the Text Frame to a number of new TF's. Draw a number of new linked TF's with the alt key pressed.
3. All Text Frames should have the Object Style set as default
4. The new TF's have an OS of [None]

3 votes
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

Hi,
This has been the behaviour since the beginning. See the link https://helpx.adobe.com/indesign/using/object-styles.html where it states “This category is applicable only if the object is an unthreaded text frame.”

Please let us know any use-cases where this can be beneficial so that we can process this as a “Feature modification request”

You can ctrl(cmd)+a in a text frame and then apply the paragraph style as a workaround.
-Aman

2 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Anonymous commented  ·   ·  Flag as inappropriate

    Hi!

    First of all, the behaviour strikes me as unintuitive. Especially funny is that actually the first linked text frame created this way (holding down alt) does, in fact, honour the default Object Style but not the subsequent ones.

    As for a use case, let's say you are flowing a long text and want to have, say, First Baseline Offset set to x height for of all the linked text frames. (Or any other object attribute.) Now, as all the text frames (save the first newly created one) have an OS of [None], there is no way to achieve this other than manually setting the correct OS for each of the frames. Even setting defaults for [Basic text frame] is useless, as the OS for the frames in [None].

  • Maria commented  ·   ·  Flag as inappropriate

    MacOS High Sierra
    InDesignCC 2018 13.1

    To recreate the bug:
    1. Create one single text frame and a few linked frames and fill them with a placeholder text (in “Basic Paragraph Style”).
    2. Create a new “Paragraph Style 1” (different from “Basic Paragraph Style”).
    3. Create a new Object Style and set its Paragraph Styles option to this new “Paragraph Style 1”.
    4. Apply this Object Style to all the frames (single and linked).
    5. Only text in the single frame will change its appearance to “Paragraph Style 1”. The linked frames will still be in “Basic Paragraph Style”.

Feedback and Knowledge Base