Bug details

Excel filter rejects custom Cell Range for 26-column sheets (.xlsx-only)

Excel filter rejects custom Cell Range for 26-column sheets (.xlsx-only)

Steps to reproduce the issues:
1. Create a new document.
2. Select File > Place, check Show Import Options, select attached Columns_26.xlsx file.
3. Note nonstandard default Cell Range: A1:A@10 (should be A1:Z10).
4. Enter custom (valid) Cell Range "A1:E5"

Expected result:
No error and a table containing cells A1 through E5.

Actual result:
Error message, "You have not entered a valid 'Cell Range'. (See attached screenshot.)

This error is given for any sheet whose right-most column is a multiple of 26 (so Z, AZ, BZ, etc.). Place the attached Columns_52.xlsx with range "A1:E5", for example.

Adding/removing a column (attached Columns_27.xlsx file) avoids the error.

Versions of Adobe InDesign:
CS6 through CC 2018.0, Windows and macOS

Test files and screenshot of error attached.

4 votes
Sign in
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Chris Roueche shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →


Sign in
Sign in with: facebook google
Signed in as (Sign out)
  • Paul commented  ·   ·  Flag as inappropriate

    I have looked further into tableFormattingOptions via javascript.

    I in fact can successfully set the following:



    but I cannot set



    When attempting to set these last two, the result is EXCEL_UNFORMATTED_TABLE.

    So, there's a bug. I'm using a Mac and CC2019. I hope this helps. Thanks!

  • Paul commented  ·   ·  Flag as inappropriate

    I also cannot set the excel import options table formatting options via script. I use the following line:

    app.excelImportPreferences.tableFormatting = TableFormattingOptions.EXCEL_FORMATTED_TABLE;

    If the UI import option panel says Unformatted before I run the script, the placed excel xlsx document remains unformatted after I run the script. If I check after running the previous line with:

    alert (app.excelImportPreferences.tableFormatting)

    I am alerted the the setting is the one I wanted, e.g. formatted, yet the resulting placed content is unformatted.

    I hope you can set me straight on this one. Thanks!

  • Monica Singh commented  ·   ·  Flag as inappropriate

    Thanks Chris, for reporting the issue!
    We are able to reproduce the issue at our end and will be investigating this further.

    Monica Singh

Feedback and Knowledge Base