Bug details

Find Glyph uses character style set in the Text tab

It's not possible to set a character style in the Glyph tab of the Find/Change window. But if you set a character style in the Text tab, the Glyph tab uses that style to limit the search scope.

Steps to reproduce:

1. Start a new document, add a character style. (Doesn't matter what formatting you add to the character style.)
2. Place a text frame and enter 'xx'.
3. Apply the character style you added in step 1 to the first x.
4. Set the character style in the Find Format field of the Text tab of the Find/Change window.
5. Go to the Glyph tab, set it to search x in the applied font.

Actual result: InDesign finds only the character to which the character style was applied.

Expected result: that InDesign finds all characters x.

(This is either a bug or an undocumented feature)

InDesign CC2018, Windows 10/64, English/International version

1 vote
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Peter Kahrel shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

Hi,
In step 4, are you setting the find format field to be the character style you have created in step step 1?
If yes, then InDesign will only find those “x” which have the character style same as in the find format field (=character style created in step 1 and applied to only first x)
https://helpx.adobe.com/indesign/using/find-change.html

Please can you elaborate a little more on the steps.

-Aman

2 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Uwe Laubender commented  ·   ·  Flag as inappropriate

    Hi Aman,
    shouldn't a Glyph Find be shielded from a Text Find and vice versa?
    FWIW: I can recreate the problem!

    How can a Character Style defined in Find Format for a Text Find action influence the Find What field of a Glyph Find?

    Best,
    Uwe Laubender
    ( ACP )

  • Peter Kahrel commented  ·   ·  Flag as inappropriate

    > In step 4, are you setting the find format field to be the character style you have created in step step 1?

    Yes, that's right.

    The point is that when you look for x using the Glyph tab, only the x in the character style is found. The Glyph search should ignore any format set in Text tab.

Feedback and Knowledge Base