Bug details

Undo does not work properly on deleted text, it only deletes one character at a time instead of whole block of text

I am on a Mac and this is a problem with InDesign 2018.

If you backspace delete two or more characters from text, undo (Ctrl+Z) only restores one character at a time instead of the whole block that was deleted in that action.

Undo worked fine in previous versions of InDesign, and it works fine in Word and other apps.

I have tried deleting InDesign preferences and caches and even reinstalled it with import previous prefereces unchecked, but the problem remains, and I cannot find any solution. Can someone please help?

Macbook Air now running High Sierra 10.13.2 (but problem was stlll there in previous versions of OSX.

5 votes
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Sarah Bond shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

3 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Amir Andriesse commented  ·   ·  Flag as inappropriate

    I was hoping the recent CC-update would have solved this, but it hasn't. Please please, Mr. Adobe, let us choose what kind of undo we want!

  • Anonymous commented  ·   ·  Flag as inappropriate

    It's not just when deleting characters but adding them too. If I'm testing 2 different words for a headline for example, I have to undo/redo 3-4 times to switch between the words. Previous versions of ID allowed me to compare both versions with 1 undo/redo. This doesn't sound like a feature to me though it might be to others. Adding a preference for undo behavior would be the best compromise.

  • Sarah Bond commented  ·   ·  Flag as inappropriate

    I have had an additional thought. If this change was deliberate (although I can't see any reason why it would be), then Adobe could offer a choice of how Undo works on text in InDesign Preferences.

Feedback and Knowledge Base