How can we improve InDesign?

Unequal inset values in an Object Style don't display in a text frame if corners are rounded

If you use an object style with unequal inset spacing and apply it to a text frame, the unequal spacing is ignore and made uniform.

Steps to recreate:
1. Create an Object Style
2. Go to 'Text Frame General Options' for that style
3. Set unequal values for 'Inset Spacing'
4. Go to 'Stroke & Corner Cptions'
5. In 'Corner Options' set 'Rounded'
6. Create a Text Frame
7. Fill Text Frame with placeholder text
8. Apply Object Style to Text Frame

Result: unequal inset spacing is ignored.

If you apply unequal inset spacing manually there are no problems — unless you apply a corner rounding greater than 6mm, at which point unequal spacing is ignored.

I've attached a screenshot of an InDesign file which demonstrates all of this.

Here's a link to the InDesign file: https://adobe.ly/2X6CVOd

As an addendum to this: object styles seem quite buggy generally. For example, if you set an initial paragraph style and select 'apply next' then later edit the paragraph style, the text frame doesn't always display the changes.

2 votes
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

BR shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

3 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Bastian S. commented  ·   ·  Flag as inappropriate

    Even it is "is as designed" - change it it's horrible.
    It would be great to have to option to do this without placing two text freames above each other.
    This is not "Resolved for the user" this is "adobe doesn't bother to fix"

    Development of Innovations / cool new features in InDesign got really slow and if there's something new it's always a clusterf* of bugs since it switched to the cloud.. listen to your users before they run away to Serif.

    Something similar happend with the Interactive PDF feature request - it got implemented really badly and then closed / ignored..

    I hope something will change soon – InDesign used to be so good :/

  • BR commented  ·   ·  Flag as inappropriate

    Sorry Ravi, but you are flat out wrong.
    Take a look at the graphic I sent you and the file I linked to. You can set up to 6mm of corner rounding and STILL have unequal inset spacing.
    It's a bug and it needs fixing.
    Please look again.
    Thank you
    Barry

  • BR commented  ·   ·  Flag as inappropriate

    For reference, I was using version 14.0.2 on MacOS 10.13.6

Feedback and Knowledge Base