Connor Mitchell

My feedback

  1. 2 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Adobe InDesign: Bugs » Performance/Usability  ·  Flag idea as inappropriate…  ·  Admin →
    Connor Mitchell shared this idea  · 
  2. 105 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    122 comments  ·  Adobe InDesign: Bugs » Performance/Usability  ·  Flag idea as inappropriate…  ·  Admin →

    Hello All,

    Following up on the comments stating that the issue is yet not fixed, we did our investigation and found that, the issues being called out in the comment section, though maybe relevant but are different than the one for which this thread was originally created.

    This particular thread caters to a very specific case which has been fixed in the last update of InDesign.

    If you continue to face performance related issues with InDesign, we sincerely request you to create a separate thread so that we can categorize the performance related issues and address them completely.
    In addition to track the performance issues effectively, it will also enable us to reach out to you in a organised manner when we investigate into each category of performance issues.

    We are extremely sorry for the troubles you are facing with InDesign and we are determined to resolve them as efficiently…

    Connor Mitchell supported this idea  · 
    An error occurred while saving the comment
    Connor Mitchell commented  · 

    So I just updated to Mojave, trashing all preferences, and completely re-installing InD 2019 CC...aaaand none of that worked.

    BUT...what did work was unlocking the locked objects on my page. Magically, everything works normally now. Thank you for wasting 2 hours of my time Adobe. FIX THIS!!!

    An error occurred while saving the comment
    Connor Mitchell commented  · 

    This is still a bug for me. extreme lag (10+ seconds). Can't even select and move and object. Literally unusable and I am working on a 5"x7" postcard with minimal graphics. Wtf Adobe??

    InDesign CC 2019 14.01, iMac 10.13.5 (high sierra; I've heard there's zero improvement with mojave so i've been waiting to install. don't want to waste WORK time just because Adobe can't publish a working product despite the massive amount of cash we fork over for it.)

Feedback and Knowledge Base